EGR Valve....strange thing happened. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 4 Old 13-03-11 Thread Starter
Status: novice oil burner.
AO Member
 
Join Date: Dec 2008
Location: United Kingdom
County: Hampshire
Posts: 222
EGR Valve....strange thing happened.

Not sure if it was a good thing to do, but I decided to unplug the electrical connector off the EGR actuator and go for a drive to see what the effects were.......LIMP MODE just coming off a roundabout.

Any thoughts.
Davey_saxo is offline  
Sponsored Links
Advertisement
 
Status: Alfa-less
AO Member
 
torque's Avatar
 
Join Date: Nov 2010
Location: United Kingdom
County: Durham
Posts: 468

Member car:

Nowt

Plug it back in
torque is offline  
(Post Link) post #3 of 4 Old 13-03-11 Thread Starter
Status: novice oil burner.
AO Member
 
Join Date: Dec 2008
Location: United Kingdom
County: Hampshire
Posts: 222
plugged back in and all was normal again......I would like to meet the inventor of EGR valve.....
Davey_saxo is offline  
roeburndale
Status: - Update
Guest
 
Posts: n/a
You have to have them turned off in the ECU software
 
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
egr , happened , thing , valvestrange

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 14-08-19 13:36
JTD/JTDM MCSF & other problems FIX losa Alfa 147, 156 & GT 154 26-09-16 20:05

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome