egr valve problems AGAIN ! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 8 Old 22-02-11 Thread Starter
Status: -
AO Member
 
jeromedeakin's Avatar
 
Join Date: Sep 2010
Location: United Kingdom
County: Nottinghamshire
Posts: 19

Member car:

147 jtd 16v mjet

egr valve problems AGAIN !

Hi need a bit of advice my egr valve has gone again found the excellent pdf file on how to fix it just need to know when ive fixed it will the engine management light go off or will i need to get it reset
jeromedeakin is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
Photodave's Avatar
 
Join Date: Dec 2008
Location: United Kingdom
County: Derbyshire
Posts: 2,012
If fixed, the light should go out after about 3 "fault free" starts. The code will stay logged in the "history" memory.
Photodave is offline  
(Post Link) post #3 of 8 Old 22-02-11 Thread Starter
Status: -
AO Member
 
jeromedeakin's Avatar
 
Join Date: Sep 2010
Location: United Kingdom
County: Nottinghamshire
Posts: 19

Member car:

147 jtd 16v mjet

Cheers for the advice ill give it go this wknd n hopefully it will solve the problem
jeromedeakin is offline  
Status: -
AO Member
 
dick dastardly's Avatar
 
Join Date: Sep 2009
Location: United Kingdom
County: Hampshire
Posts: 184

Member car:

gt

Just get the thing turned off or blank it off all together. Your car will run much better and stop all that exhaust rubbish going back into your engine.
dick dastardly is offline  
(Post Link) post #5 of 8 Old 22-02-11 Thread Starter
Status: -
AO Member
 
jeromedeakin's Avatar
 
Join Date: Sep 2010
Location: United Kingdom
County: Nottinghamshire
Posts: 19

Member car:

147 jtd 16v mjet

Im thinking about doing this in the summer i want a ecu remap n ill get the egr cut off then
no more egr probs
jeromedeakin is offline  
(Post Link) post #6 of 8 Old 22-02-11 Thread Starter
Status: -
AO Member
 
jeromedeakin's Avatar
 
Join Date: Sep 2010
Location: United Kingdom
County: Nottinghamshire
Posts: 19

Member car:

147 jtd 16v mjet

just cleaned my egr valve solenoid pin was sticking. took her 4 a test drive and everythings fine but the engine light aint reseting itself any advice whether i need 2 take it to someone 2 get it sorted or will it eventually go away
jeromedeakin is offline  
Status: -
AO Member
 
AMIKO's Avatar
 
Join Date: Dec 2008
Location: Georgia
County: Tbilisi
Posts: 113
I have these errors.
Can it be EGR Valve problem?
Attached Images
File Type: jpg alfa 159 25.06.2013-1.JPG (25.5 KB, 18 views)
AMIKO is offline  
Status: Busy busy busy!
Club Member
Membro Premio
 
Pud237's Avatar
 
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 44,880
Quote:
Originally Posted by AMIKO View Post
I have these errors.
Can it be EGR Valve problem?
No, sounds like possible stretched timing chain or maybe the exhaust cam sensor is faulty.
Pud237 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
egr , problems , valve

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 14-08-19 13:36
EGR valve problems Mito JTDM mattgallon Alfa MiTo 5 21-09-10 07:35
Is this how to remove egr valve (1.9JTDM) ? Mr Bacchus Alfa 147, 156 & GT 4 18-05-08 10:11
Running problems on 1.9 JTD 16V 147 MAF EGR issues JayL Alfa 147, 156 & GT 3 22-04-08 12:18
EGR Valve badgers_nadgers Alfa 164 & 166 3 26-01-07 17:09

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome