beware the waterpump - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 2 Old 21-02-11 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: United Kingdom
County: Suffolk
Posts: 215

Member car:

147 JTD, YZF600R

beware the waterpump

Just taken the waterpump out for a check, while rebuilding the head, to find a fair bit of shaft play. +/- 0.5mm impeller, very visible movement

This pump is less than 25Kmiles (replaced with timing belt), and has visible play in the bearing. Since I have ordered a replacement.

Beware waterpump failure!.. Wear will sudenly accelerate when the bearing becomes more and more inefficient..
stefz is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
Photodave's Avatar
 
Join Date: Dec 2008
Location: United Kingdom
County: Derbyshire
Posts: 2,012
Well known issue on the 16v and 20v. However they're usually expected to last 55k-ish!

Gotta say that when I did the belt on mine at around 50k the water pump seemed absolutely fine. Still changed it, mind!
Photodave is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
beware , waterpump

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Important Information regarding the JTD 16v and 20v Waterpump Spider95 Alfa 147, 156 & GT 2 24-02-10 11:28

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome