Engine Mis Firing - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 9 Old 02-01-11 Thread Starter
Status: Chillin
AO Silver Member
 
Chocoboy's Avatar
 
Join Date: Dec 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 5,621

Member car:

2005 147 JTD

Engine Mis Firing

hey there everyone, i'm asking on behalf of a friend now i'm afraid it's not an alfa but he's having a problem with his Vauxhall Astra Mis-firing, the work that's already been done is the following Ihead gasket, valves, water pump, thermostat, valve stem oil seals, camshaft, timing belt ,Temperature sensor, coil pack, spark plugs, rebuilt the carb.

it's a T Reg 1.6 if that's any help, any ideas would be appreciated
Chocoboy is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
kevarino's Avatar
 
Join Date: Dec 2010
Location: United Kingdom
County: East Sussex
Posts: 10

Member car:

156 2.0 JTS Ti

I had one once on an astra petrol, took the head off and replaced the valves on customers say so. Still misfiring when put back together, after abit of faffing about found out it was an injection ecu fault, quite common apparently!
kevarino is offline  
(Post Link) post #3 of 9 Old 02-01-11 Thread Starter
Status: Chillin
AO Silver Member
 
Chocoboy's Avatar
 
Join Date: Dec 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 5,621

Member car:

2005 147 JTD

ok thanks for the suggetsion i'll pass it on,
Chocoboy is offline  
Status: faclifting a 156
AO Silver Member
 
biffa's Avatar
 
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
ECU fault after a coil pack failure quite common... Seems moisture gets into the coil pack and can send some hefty voltage to the ECU...
biffa is offline  
(Post Link) post #5 of 9 Old 04-01-11 Thread Starter
Status: Chillin
AO Silver Member
 
Chocoboy's Avatar
 
Join Date: Dec 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 5,621

Member car:

2005 147 JTD

cheers
Chocoboy is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,115
Garage
mmm agreed. samething happens of on the 206 injectors frying the ecu. Can he get a donor ecu from ebay or something?
Joss is offline  
(Post Link) post #7 of 9 Old 04-01-11 Thread Starter
Status: Chillin
AO Silver Member
 
Chocoboy's Avatar
 
Join Date: Dec 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 5,621

Member car:

2005 147 JTD

not a clue he's gonna get it hooked up to diagnostics, will it show any errors if this is the cause?
Chocoboy is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,115
Garage
If the ECU is faulty then it may show ECU fault code or it may not show a fault at all as it faulty.... if that makes sense
Joss is offline  
(Post Link) post #9 of 9 Old 05-01-11 Thread Starter
Status: Chillin
AO Silver Member
 
Chocoboy's Avatar
 
Join Date: Dec 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 5,621

Member car:

2005 147 JTD

yeah it does Thanks
Chocoboy is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , firing , mis

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 14-08-19 13:36
16 important OIL questions and answers oilman Alfa 147, 156 & GT 339 03-06-18 10:39
Mito clover (and other Alfa propaganda) Toronto Spider General Alfa Discussion 4 10-09-09 09:14
alfa 156 tuning belfast bob Tuning & Upgrades 29 25-06-08 20:35
Which one is the best goldstud Tuning & Upgrades 17 24-06-08 11:50

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome