147 JTD m-jet oil smoke! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 5 Old 20-12-10 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: United Kingdom
County: Suffolk
Posts: 215

Member car:

147 JTD, YZF600R

147 JTD m-jet oil smoke!

Hi all,

Trying to diagnose a problem. Started the car up (no problem) after a week sat still on the drive-way in the cold weather..

Started up fine, drove out, and within a few minutes noticed lots of smoke in the headlights of cars behind when accelerating, on light throttle very little if none visable at all.

The smoke was buring oil, but not sure where its burning from..

could the turbo seals have 'suddenly' gone ? what are other peoples experience..

even when idleing you can smell the oil in the exhaust..
stefz is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
markmoto's Avatar
 
Join Date: Feb 2008
Location: United Kingdom
County: Merseyside
Posts: 729

Member car:

Various Alfa's

sure its not just condensation does it dissipate quickly or linger? if your not sure id get it looked at asap if it is the turbo seals you want to catch if before damage to the engine is done.
markmoto is offline  
CJO
Status: Enjoying a nice mug of tea
AO Silver Member
 
Join Date: Oct 2008
Location: United Kingdom
County: Bedfordshire
Posts: 1,752
Also check for air leaks / splits in the turbo pipes as this can cause smoke as well.
CJO is offline  
(Post Link) post #4 of 5 Old 21-12-10 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: United Kingdom
County: Suffolk
Posts: 215

Member car:

147 JTD, YZF600R

definately oil smoke, not unburnt diesel. It has performance when on throttle, but with blooms of thick oil smoke when the turbo comes on boost.. and a tiny bit of oil smoke when off boost
stefz is offline  
(Post Link) post #5 of 5 Old 22-12-10 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: United Kingdom
County: Suffolk
Posts: 215

Member car:

147 JTD, YZF600R

..can turbo seals 'suddenly' fail.? I remember driving then suddenly noticing the smoke.. hadn't smoked at all up untill this point. Could the cold weather have made the rubber seals fail?

milage 78K
stefz is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
147 , jtd , mjet , oil , smoke

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
16 important OIL questions and answers oilman Alfa 147, 156 & GT 339 03-06-18 10:39
So how many and where are the GTA's ??? 156GTASW Alfa GTA 608 27-10-11 09:11

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome