2.4 10v Glowplugs? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 5 Old 29-11-10 Thread Starter
Status: Back in the fold!
AO Member
 
Reedy147's Avatar
 
Join Date: Oct 2009
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 320

Member car:

147 JTD

Help 2.4 10v Glowplugs?

Hi there all! I appear to need to change the glowplugs as the car is not starting and Alfadiag threw up a preheat fault code... so pretty sure about it!

Questions are:

* Are Bosch or NGK plugs worth the extra - ie, £40 opposed to £20 odd for "x" brand?
* Is there a how to! Have tried searchung the forum, but not had a great deal of success!

Many thanks

Reedy
Reedy147 is offline  
Sponsored Links
Advertisement
 
Status: Arggghhhhh
AO Member
 
Alfa 156 JTD's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
County: Greater London
Posts: 207

Member car:

Alfa 156 2.4 JTD

Hi

They are easy to remove.

But you have to be careful.

Do all work from behind the inlet manifold, this way you wont damage the spill pipes and plastic "t pieces" across the diesel injectors.

Wiggle the connectors off the glow plugs gently then use a long extension so the ratchet is just above the top of inlet manifold, there's just enough room and they come out easy.

As for what type to use, I always believe you get what you pay for
Alfa 156 JTD is offline  
(Post Link) post #3 of 5 Old 03-12-10 Thread Starter
Status: Back in the fold!
AO Member
 
Reedy147's Avatar
 
Join Date: Oct 2009
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 320

Member car:

147 JTD

Thank you for that!

I think it may actually be the air con relay causing the non start?... maybe?...

Will see! Will be getting the NGK plugs I think anyway.

Thank again!!

Reedy
Reedy147 is offline  
Status: -
AO Member
 
markmoto's Avatar
 
Join Date: Feb 2008
Location: United Kingdom
County: Merseyside
Posts: 729

Member car:

Various Alfa's

Quote:
Originally Posted by Reedy156 View Post
Thank you for that!

I think it may actually be the air con relay causing the non start?... maybe?...

Will see! Will be getting the NGK plugs I think anyway.

Thank again!!

Reedy
If one or more of your glow plugs is defective your glow plug warning light should flash after the car has started and you will also have a fault code for the plugs, the aircon relay will not be preventing it from starting, these still start prity good even with 2 or even 3 duff plugs is it cranking but not firing? Hardest one to get to is number 1 rest are prity easy althought you will need a deep 10mm socket and a uj flexible joint to get the right angle. Doesnt realy matter which make you get beru are normaly the cheapest and imo as good as bosch.

markmoto is offline  
(Post Link) post #5 of 5 Old 06-12-10 Thread Starter
Status: Back in the fold!
AO Member
 
Reedy147's Avatar
 
Join Date: Oct 2009
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 320

Member car:

147 JTD

Quote:
Originally Posted by MotoTech View Post
If one or more of your glow plugs is defective your glow plug warning light should flash after the car has started and you will also have a fault code for the plugs, the aircon relay will not be preventing it from starting, these still start prity good even with 2 or even 3 duff plugs is it cranking but not firing? Hardest one to get to is number 1 rest are prity easy althought you will need a deep 10mm socket and a uj flexible joint to get the right angle. Doesnt realy matter which make you get beru are normaly the cheapest and imo as good as bosch.
It was cranking like hell - but not firing - fuel under good pressure engine side of filter, so will hope that the plugs sort it - just ordered all 5 and got NGK's.

Will let you know how I get one... thanks for your help....

Reedy
Reedy147 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
10v , glowplugs

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome