Alfa 159 2.4 jtdm 200 HP problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 13-11-10 Thread Starter
Status: Trying to fix my 159
AO Member
 
Join Date: Feb 2010
Location: Spain
County: Valencia
Posts: 117

Member car:

Alfa 159 2.4

Alfa 159 2.4 jtdm 200 HP problems

Hy there. Well, I have o couple of problems with my 2.4 engine. First is that in low revs I donīt have power at all. From 1.000 rpm till 2.000 rpm I donīt have power, the car runs like it has 100 PS or less and when it reachs the 2.000 rpm it seems that it cames a little to live, but it doesnīt have the joy of the 200 HP. The second problem it that with the car stopped, with the engine on, it shakes a lot, you can feel a very strange vibracion inside the car, and if you move the wheels, you can observe that the revs also changer, I mean that goes un and down about 10-20 revs. Any sugestions?
adrianuxx is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Sep 2010
Location: United Kingdom
County: West Midlands
Posts: 106
Sound like you needs new plugs


Sent from my iPhone using Tapatalk
Ferron Hudson is offline  
Status: -
AO Member
 
vesku's Avatar
 
Join Date: Jan 2010
Location: Finland
County: Etela-Suomen Laani
Posts: 67
Sounds very much like jammed EGR-valve.
vesku is offline  
Status: Ich habe entscheiden.
AO Gold Member
 
filipharvey's Avatar
 
Join Date: Jun 2007
Location: United Kingdom
County: Norfolk
Posts: 7,207

Member car:

Alfa GT JTD

Quote:
Originally Posted by Ferron Hudson View Post
Sound like you needs new plugs
Not on a diesel. :slap:

Does it make any whistling sounds at all? That could indicate an air leak somewhere.
filipharvey is offline  
(Post Link) post #5 of 6 Old 24-11-10 Thread Starter
Status: Trying to fix my 159
AO Member
 
Join Date: Feb 2010
Location: Spain
County: Valencia
Posts: 117

Member car:

Alfa 159 2.4

Quote:
Originally Posted by filipharvey View Post
Not on a diesel. :slap:

Does it make any whistling sounds at all? That could indicate an air leak somewhere.
Hy . There is no air leak because I have check it , and everything fine. Turbo presure fine, with Fiat ecu scan all values are ok, but i still have no power.
adrianuxx is offline  
Status: -
AO Member
 
manettino's Avatar
 
Join Date: Nov 2011
Location: Monaco
County: Monte-Carlo
Posts: 36
Quote:
Originally Posted by adrianuxx View Post
Hy there. Well, I have o couple of problems with my 2.4 engine. First is that in low revs I donīt have power at all. From 1.000 rpm till 2.000 rpm I donīt have power, the car runs like it has 100 PS or less and when it reachs the 2.000 rpm it seems that it cames a little to live, but it doesnīt have the joy of the 200 HP. The second problem it that with the car stopped, with the engine on, it shakes a lot, you can feel a very strange vibracion inside the car, and if you move the wheels, you can observe that the revs also changer, I mean that goes un and down about 10-20 revs. Any sugestions?
your DPF filter is blocked or the EGR VALVE IS STUCK open, Both Easy to FIX
manettino is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
159 , 200 , alfa , jtdm , problems

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
159 2.4 jtdm overboost problems? tiptap Tuning & Upgrades 1 13-04-10 17:31

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome