Jtd engine noise eml - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 15-10-10 Thread Starter
Status: -
AO Member
 
155_Baglio's Avatar
 
Join Date: Oct 2008
Location: United Kingdom
County: Tyne and Wear
Posts: 21
Garage
Jtd engine noise eml

Just wondering if anyone can help, I have a 2001 156 2.4JTD I`ve noticed recently a noise which sounds like a jet engine when I accelerate, I immediately thought the turbo, so I checked the pipes and the intake pipe was split, I replaced it and the bottom hose looks fine however the noise is still there. The turbo works perfectly fine at low revs with the car pulling hard through the gears up to 50mph. The engine management light then comes on after that and the turbo seems to cut out, releasing the accelerator makes the light go out and if I press it again slightly the turbo comes back in.
I am assuming it is the turbo but I dont want to spend money on a recon turbo if its a problem such as the intercooler etc, I dont have any experience with TD`s so any help would be appreciated!
155_Baglio is offline  
Sponsored Links
Advertisement
 
Status: Now I need a newclutch and a battery
AO Member
 
AlfaV6 Alan's Avatar
 
Join Date: Apr 2010
Location: United Kingdom
County: Hampshire
Posts: 90
Get someone to scan it that may help you to find out whether or not its electronic like a sensor or the EGR valve .A scan should cost around £40 quid
AlfaV6 Alan is offline  
(Post Link) post #3 of 3 Old 16-10-10 Thread Starter
Status: -
AO Member
 
155_Baglio's Avatar
 
Join Date: Oct 2008
Location: United Kingdom
County: Tyne and Wear
Posts: 21
Garage
Yes it looks that might be the way to go, The car actually broke down today. The engine management light came on and the turbo cut out as usual, so I did as normally do and lifted off, only this time the engine cut out, I tried 4 times to start it, the engine turned over but it wouldn`t fire, I left the car for an hour and returned with a tow rope only to find it fired up straight away, strange!
155_Baglio is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
eml , engine , jtd , noise

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 14-08-19 13:36
Mito clover (and other Alfa propaganda) Toronto Spider General Alfa Discussion 4 10-09-09 09:14
Disturbing JTD 2.4 Engine noise Daytona Alfa 147, 156 & GT 9 27-12-08 19:15
156 facelift 1.9 JTD Vibrating engine noise & knocking noise Map_lad Alfa 147, 156 & GT 0 22-12-08 10:15
2.4 jtd flatspot bruce Alfa 147, 156 & GT 31 11-05-08 09:08

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome