cam belt snapped on my 156 2.4 jtd ti - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 10 Old 16-08-10 Thread Starter
Status: -
AO Member
 
Join Date: Aug 2010
Location: United Kingdom
County: Midlands
Posts: 11

Member car:

Alfa 156 item ti

cam belt snapped on my 156 2.4 jtd ti

HI all, my cambelt has snapped on my 156 jtd ti i was driving along when everything just cut out with no warning. at the point when it cut out there were no clunks or bangs, im hoping this is a good thing, but then i tried stating her, would that of caused any further damage???
can anyone help me in my quest to find a cheap but quality repair please! im quite wary of getting screwed over to be quite honest. i live near Tamworth if anyone knows anywhere. thanks
Challbone is offline  
Sponsored Links
Advertisement
 
Status: playing kill by numbers
AO Gold Member
 
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 8,786
damage has been done already, you're not likely to hear the piston hit the valves, bending the rockers...

no further damage from trying to start.. fit new rockers + new belt and try to start.... and look into the reason for the failure, maybe waterpump?
Cuore_Sportivo_155 is offline  
Status: Anonima Lombarda Fabbrica Automobili
AO Member
 
keepRolling's Avatar
 
Join Date: Sep 2009
Location: South Africa
County: Gauteng
Posts: 975
Bottom end may also need to be done.
keepRolling is offline  
(Post Link) post #4 of 10 Old 16-08-10 Thread Starter
Status: -
AO Member
 
Join Date: Aug 2010
Location: United Kingdom
County: Midlands
Posts: 11

Member car:

Alfa 156 item ti

how much is all that going to cost roughly? it sounds like the garrage is saying i need more than just that work doing. i obviously dont know until you open it up but worried they will try and make a big job out of something that only needs a small ammount doing, any further advice???
Challbone is offline  
Status: Always working
Identity Confirmed
Authorised Trader
 
Autolusso's Avatar
 
Join Date: Feb 2007
Location: United Kingdom
County: Bedfordshire
Posts: 7,039
Quote:
Originally Posted by Challbone View Post
HI all, my cambelt has snapped on my 156 jtd ti i was driving along when everything just cut out with no warning. at the point when it cut out there were no clunks or bangs, im hoping this is a good thing, but then i tried stating her, would that of caused any further damage???
can anyone help me in my quest to find a cheap but quality repair please! im quite wary of getting screwed over to be quite honest. i live near Tamworth if anyone knows anywhere. thanks
You say it is a Ti so I assume it is a 2.4 JTD 20v, correct ? If so it will be about a grand depending on the damage, if you want it fixed correctly we are here to help

I think you talked to me today but I quoted you 850 as you said it was a 2.0 petrol, give me a call to clarify

Ned
Autolusso is offline  
Status: Saving for engine.
AO Silver Member
 
tomfromtelford's Avatar
 
Join Date: Jun 2007
Location: United Kingdom
County: Shropshire
Posts: 4,241
Don't they have rockers that snap like a 16v??
tomfromtelford is offline  
Status: Saving for engine.
AO Silver Member
 
tomfromtelford's Avatar
 
Join Date: Jun 2007
Location: United Kingdom
County: Shropshire
Posts: 4,241
P.S. Simply alfas are fairly close in Dudley area.
tomfromtelford is offline  
Status: playing kill by numbers
AO Gold Member
 
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 8,786
the cheapest way is to take off the cam cover, repair all damage there, fit a new belt and try to start... if you need to replace the valves, you haven't bought anything yet you won't need anyway.... if you don't need to replace the valves the jobs done...

you can likely see valve damage with the valve cover off anyway....
Cuore_Sportivo_155 is offline  
Status: -
Newbie
 
Join Date: Aug 2010
Location: United Kingdom
County: -
Posts: 3

Member car:

Pug 106 1.5d

I've had a camshaft slip on my car before and trust me you can hear the pistons hit the valves. If you didn't hear a loud metallic banging sound as it broke there is a good chance the valves haven't bent.

I agree with Cuore Sportivo.
Jason_A_S is offline  
Status: Brera 2.4 jtd 500 abarth
AO Member
 
alfatwice's Avatar
 
Join Date: Mar 2006
Location: wickford essex
Posts: 910
My cam belt snapped at 64000 miles on a 2.4 jtd 20 v , it had broken the rockers apparently that's what they are designed to do to save anymore serious damage , they also changed the water pump while they had stripped down . It was all done on warrenty . But was told it as 1200 quids worth of work .
alfatwice is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
156 , belt , cam , jtd , snapped

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
So how many and where are the GTA's ??? 156GTASW Alfa GTA 608 27-10-11 09:11

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome