156 2.5 V6 Tempature gauge & fans not working, stalling when hot! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 11-05-10 Thread Starter
Status: 156 3.0 V6 under construction
AO Member
 
Mr Mischief's Avatar
 
Join Date: Jun 2008
Location: United Kingdom
County: Greater London
Posts: 65
Help 156 2.5 V6 Tempature gauge & fans not working, stalling when hot!

Hey Alfa Gods,

In need of your expertise yet again....

I have a 2000 W 156 2.5 V6 75,000 FSH.

My temperature gauge doesnt work and my fans dont kick in, and when hot idle stall!?

I have changed the cambelts, aux belt, water pump, tensioners, lamda, maf, temp sensor, new air and oil filters, coolant, oil, stainless decat system, plugs, battery, cleaned all connections & multi plugs & fuses including fan 40 amp fuses in engine bay, cleaned throttle body, it also had the thermostat removed by someone previously so I have one coming that I will fit. I think engine bay was steam cleaned by previous owner which I think is a bad thing right??? Also once the engine is hot when reved up it seems to dip very low and sometimes nearly stalls or catches itself and bring back to idle, dont know if this is due to fans not working?? I have just got Alfa Diag so can use this too. Would really appreciate any helpe as its hurting my pocket and head now!?

Many Thanks

Danny
Mr Mischief is offline  
Sponsored Links
Advertisement
 
Status: Rh - C8H18
AO Member
 
Speedmaster's Avatar
 
Join Date: Nov 2009
Location: Bulgaria
County: Stara Zagora
Posts: 377
Garage
Did fans kicks when temp sensor plug removed????
Speedmaster is offline  
(Post Link) post #3 of 3 Old 11-05-10 Thread Starter
Status: 156 3.0 V6 under construction
AO Member
 
Mr Mischief's Avatar
 
Join Date: Jun 2008
Location: United Kingdom
County: Greater London
Posts: 65
Yes they kicked in immediately, gona buy a couple of fan resistors & see what happens, cheers guys
Mr Mischief is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
156 , fans , gauge , hot , stalling , tempature , temperature , working

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
So how many and where are the GTA's ??? 156GTASW Alfa GTA 608 27-10-11 09:11

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome