jtd 105 woes - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 5 Old 19-04-10 Thread Starter
Status: -
AO Member
 
GIRLRACER's Avatar
 
Join Date: Jul 2004
Location: Timbuckto at the Moment
Posts: 126

Member car:

156. V6... Mmmm

jtd 105 woes

Hi guys its been a while but i no longer own an alfa i have a 2001 wrx

Anyhow, i am asking you guys for some help please.

My other half has bought a fiat marea 105 jtd its a 2000 model and is having some problems but the fiat forum although massive have failed to help him out at all and he knows they fit these engines in alfas so has asked me to try and get help from the nice people on here as you were always great in the past when we both had alfas

His problem is it starts/runs fine then after a couple of miles it stalls, and wont restart for 20 mins or so? then it runs again and does the same thing over and over, he doesnt really wanna spend loads on it as he has lost his job and has no cash

The car is also only a stop gap really till he takes his ex-boss to a tribunal

Can anyone advise on what is the most likely cause please? its a 2000 car and doesnt appear to have the normal diagnostic plug anywhere to be seen?

What he has been able to read so far points to crank sensor but other people have said the start /stop solenoid, the fuel pump/ the high pressure regulator and he cant afford to buy one after another

Thanks in advance for any help

Tina x

Tina
GIRLRACER is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Feb 2010
Location: United Kingdom
County: Essex
Posts: 301

Member car:

156

Hi Tina - my guess would be crankshaft sensor but would suggest taking it to a specialist and plugging into diags - it will cost between 45 and 90 pounds dependant on where you go but at least the problem will isolated
alfa amore is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,115
Garage
mmm. i'll second that. Quite a standard symptom
Joss is offline  
(Post Link) post #4 of 5 Old 26-04-10 Thread Starter
Status: -
AO Member
 
GIRLRACER's Avatar
 
Join Date: Jul 2004
Location: Timbuckto at the Moment
Posts: 126

Member car:

156. V6... Mmmm

Thanks for the help chaps it was the crank sensor

Diagnostics wouldnt have helped as there was no fault showing on the eml but thanks for the suggestion

Mick

Last edited by GIRLRACER; 26-04-10 at 12:04. Reason: added info
GIRLRACER is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,115
Garage
Pleased to help!
Joss is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
105 , jtd , woes

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Diagnostic software freeware? 156head Alfa 147, 156 & GT 27 18-03-10 14:24

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome