JTDm Ticking - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 9 Old 15-04-10 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: United Kingdom
County: Bristol
Posts: 12

Member car:

156

JTDm Ticking

Hi Guys, I have a problem with my JTD that I hope people can help with.

on accelleration there seems to be a small hesitation, but mainly on lift off, or when clutch is engaged at slow speeds/ stop start there seems to be a ticking noise like a cross between a clock and a creaking door . A garage has confirmed no ECU codes, but at least this is annoying and seems to be a problem.

help much appreciated
paul_k_carroll is offline  
Sponsored Links
Advertisement
 
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,115
Garage
Does it do it if you put it in first and hold it lightly on the clutch and rev it? As you come off the gas its makes a ticky/creak noise? If so I have the same noise and have heard it on many a jtd. I have investigated the whole side of the engine changing cambelts and idlers galore. Can't find it and it would not seem to be very serious as i've had it since i've had the car (2 years). bloomin annoying though
Joss is offline  
(Post Link) post #3 of 9 Old 23-04-10 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: United Kingdom
County: Bristol
Posts: 12

Member car:

156

yep that sounds about right, my impresion was that it's related to the air intake in some form, either a leak in air pipes or wastegate, simply because it seems t be when boost should be high but it isn't being used
paul_k_carroll is offline  
(Post Link) post #4 of 9 Old 23-04-10 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: United Kingdom
County: Bristol
Posts: 12

Member car:

156

... amd my impression is that ther is a bit more lag that may be related as well
paul_k_carroll is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,115
Garage
I have some flat spots but everyone says that they all have it. I know its not a leak in the air pipes as it would belch black smoke out the back! (well more than a normal jtdm) And i've checked em carefully. Waste gate could be the issue. I find if I press the throtle and release the revs stay up for a fraction of a second. Like the boost is stying on. Maybe the wastegate is at fault?

Mine doesn't lag rally though although comes on boost aroun 1750 rpm. Same as yours??
Joss is offline  
(Post Link) post #6 of 9 Old 23-04-10 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: United Kingdom
County: Bristol
Posts: 12

Member car:

156

... no flat spots when te car is accellerating it goes well until a wall when power stops. I have't checked when boost comes on however so will check (good excuse to give it some!)
paul_k_carroll is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,115
Garage
My diesel does run out of puff a bit after 4k. Wouldn't call it a wall as diesels don't rev and i'd expect it to do that. There are a coupek of flat spots in the map. Can't quite remember where they are but I did query it on here and everyone seemed to think it was just the poor alfa map
Joss is offline  
(Post Link) post #8 of 9 Old 26-04-10 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: United Kingdom
County: Bristol
Posts: 12

Member car:

156

...Would definately consider a new one, anyidea of a good un?
paul_k_carroll is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,115
Garage
Well thats the stage i'm at too. I'll put a post up. Hopefully there is one inbetween bournemouth and bristol so both of us so we can both get to it!
Joss is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
jtdm , ticking

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome