TS oil pump. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 15 Old 18-02-10 Thread Starter
Status: Yes I'm back! hehe.
AO Silver Member
 
TheMystic's Avatar
 
Join Date: Feb 2009
Location: South Africa
County: Gauteng
Posts: 1,436
TS oil pump.

Hi all. I thought someone might get kick of of seeing what the inside of the oil pump looks like.

So I snapped a few shots while I have mine open.

More pic's here http://s842.photobucket.com/albums/z...%20oil%20pump/
Attached Images
File Type: jpg DSC00325.jpg (89.2 KB, 41 views)

Last edited by TheMystic; 11-02-12 at 17:39.
TheMystic is offline  
Sponsored Links
Advertisement
 
Status: Hey Joe...
AO Gold Member
 
iainfm's Avatar
 
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,274

Member car:

Jaaaaag

Consider me kicked

What are you doing to it?
iainfm is offline  
Status: Needs a thermostat
AO Silver Member
 
10,500RPM's Avatar
 
Join Date: Feb 2009
Location: Ireland
County: -
Posts: 3,263
Quote:
Originally Posted by iainfm View Post
What are you doing to it?
Opening it for kicks





I love gearbox internals


GSXR gearbox
Attached Images
File Type: jpg th_P8050261.jpg (5.5 KB, 176 views)
10,500RPM is offline  
Status: senior
AO Member
 
electroboy's Avatar
 
Join Date: Jun 2009
Location: Bosnia and Herzegovina
County: Zapadnohercegovacka Zupanija
Posts: 108
Pics are wery useful if someone wants to measure clearances between gears and housing...Here is how oil pump looks like on 2.0 V6 TB, same as on 2.5 and 3.0
Attached Images
File Type: jpg DSCF2712.jpg (68.0 KB, 26 views)
electroboy is offline  
(Post Link) post #5 of 15 Old 19-02-10 Thread Starter
Status: Yes I'm back! hehe.
AO Silver Member
 
TheMystic's Avatar
 
Join Date: Feb 2009
Location: South Africa
County: Gauteng
Posts: 1,436
haha,

No I opened it to clean all the little bits of crank shaft out. I was hoping in preperation for putting it motor back in.

Only that's not really the case any more. I got a Quote on the outstanding parts list and it still at R11,000. So it'll be a while yet. Thats just short of 1,000 Pounds for the guys in the UK.
TheMystic is offline  
Status: Looking for a V6 again
AO Member
 
TOPKIT's Avatar
 
Join Date: Sep 2007
Location: United Kingdom
County: Kent
Posts: 491
Chilling

Did all of those cigerette dog ends and ash come out of that oil pump !! LOL
Being serious now very interesting pictures and always useful to some of us Thanks for posting them.
TOPKIT is offline  
Status: Needs a thermostat
AO Silver Member
 
10,500RPM's Avatar
 
Join Date: Feb 2009
Location: Ireland
County: -
Posts: 3,263
Quote:
Originally Posted by TheMystic View Post
I got a Quote on the outstanding parts list and it still at R11,000. So it'll be a while yet. Thats just short of 1,000 Pounds for the guys in the UK.
What happened to the engine? I'm assuming oil pump failure and it needs a full rebuild.
10,500RPM is offline  
(Post Link) post #8 of 15 Old 20-02-10 Thread Starter
Status: Yes I'm back! hehe.
AO Silver Member
 
TheMystic's Avatar
 
Join Date: Feb 2009
Location: South Africa
County: Gauteng
Posts: 1,436
Quote:
Originally Posted by 10,500RPM View Post
What happened to the engine? I'm assuming oil pump failure and it needs a full rebuild.
No Oil pump is fine other than the bits in it. The cause was a failed big end and that was due to a incorrect repair of a cam belt failure.

I'm rebuilding the engine, see here: https://www.alfaowner.com/Forum/south...-147-sele.html
TheMystic is offline  
Status: playing kill by numbers
AO Gold Member
 
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 8,786
and still there are a lot of people who don't believe that the bearings took a bashing after a cambelt failure....
Cuore_Sportivo_155 is offline  
Status: pothole avoidance score - 9 out of 10
AO Silver Member
 
Laptop_Matt's Avatar
 
Join Date: Dec 2006
Location: United Kingdom
County: Derbyshire
Posts: 3,047
Garage
Quote:
Originally Posted by TOPKIT View Post
Did all of those cigerette dog ends and ash come out of that oil pump !! LOL
Being serious now very interesting pictures and always useful to some of us Thanks for posting them.
Was gonna say that myself,

Did you smoke all of them while taking it out? lol

TS oil pump looks cooler than V6
Laptop_Matt is offline  
(Post Link) post #11 of 15 Old 28-02-10 Thread Starter
Status: Yes I'm back! hehe.
AO Silver Member
 
TheMystic's Avatar
 
Join Date: Feb 2009
Location: South Africa
County: Gauteng
Posts: 1,436
Quote:
Originally Posted by Cuore_Sportivo_155 View Post
and still there are a lot of people who don't believe that the bearings took a bashing after a cambelt failure....
Yeah. I had a stand up fight with the workshop manager about replacing the big ends. After yelling at each other for a while, he then resorted to the tactic of out pricing the work. Told me if I wanted the big ends changed the job was going to cost me an extra 1000 pounds. So I dropped it. What I should have done was take it to an indi to get them done. Well in hind sight what I should have done was buy another car, from another dealership, but anyway.

That dealership no longer exists, but that same bloke is now workshop manager for another dealership. I refuse to deal with them, not even for spares. On the grounds that they have hired a thief and a liar, I can only assume that the whole place indorses thievery and cheating.


Oh and if you read this: You know who you are.
Up yours and F you!
It's come to my attention that you and your cohorts ghost on the forum, lacking the balls to resister be known. Like the petty, sneaking, thieves and lairs that you are.

Wow, where did that come from?

Sorry guys.
I'm just so riled up by this. This car is meant to be my daily. So I've been without a car for a very long time now and unless I get a loan, it's going to still be off the road till late this year, if not next year.

Keithy says: "I think you put too much sugar on your cornflakes! "
TheMystic is offline  
Status: -
AO Member
 
ssomers's Avatar
 
Join Date: Oct 2009
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 22
My TS oil pump is leaking (a few ml a second) through the new cranshaft seal - stripped cleaned and STILL does it
How can the seal be seeing any pressure from the pump?
Problem still to solve - but need car for work!
ssomers is offline  
(Post Link) post #13 of 15 Old 01-03-10 Thread Starter
Status: Yes I'm back! hehe.
AO Silver Member
 
TheMystic's Avatar
 
Join Date: Feb 2009
Location: South Africa
County: Gauteng
Posts: 1,436
Quote:
Originally Posted by ssomers View Post
My TS oil pump is leaking (a few ml a second) through the new cranshaft seal - stripped cleaned and STILL does it
How can the seal be seeing any pressure from the pump?
Problem still to solve - but need car for work!
I may be that you damaged the seal when putting it in. I've done this. It's really easy to hurt the little lip and that it all it needs.
TheMystic is offline  
Status: -
AO Member
 
ssomers's Avatar
 
Join Date: Oct 2009
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 22
Public Humiliation

After a bottom end rebuild - I was getting too hasty

Oil seal - IN WRONG WAY ROUND - doh

2.50 seal and my caboose is back on the rails
ssomers is offline  
(Post Link) post #15 of 15 Old 11-03-10 Thread Starter
Status: Yes I'm back! hehe.
AO Silver Member
 
TheMystic's Avatar
 
Join Date: Feb 2009
Location: South Africa
County: Gauteng
Posts: 1,436
I put some more pics up here: 147 oil pump pictures by themystic - Photobucket
TheMystic is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
oil , pump

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil for Modded Cars oilman Tuning & Upgrades 0 09-06-09 20:42
Help Oil disappearing Little Miss Alfa 147, 156 & GT 34 25-05-06 12:04
Oil Consumption & Selespeed pump relay zkrige Alfa 147, 156 & GT 9 22-05-06 09:20
Selespeed oil pump hotwheels Alfa 147, 156 & GT 2 31-01-06 16:52

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome