Engine Mangement Light on (before ignition) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 8 Old 18-02-10 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2010
Location: United Kingdom
County: Leicestershire
Posts: 22
Engine Mangement Light on (before ignition)

Hello, now this might be completely normal but, when I turn the key on my 147 TS Petrol engine the warning lights come on to tell me that they are all still working as they should. But, one of them stays on until the engine is running. The offending light is one which looks like a little engine or gear box. No warning messages/codes come up on the display so Iím wondering if this is normal.

I have read the manual and it says that the lights should come on for 4 seconds then go off. It also says if the lights come on when running/driving the car then there is a problem. But it says nothing about the light staying on prior to ignition.

Having only had the car 3 days I am a little jumpy about any noise rattle or warning light which should not be there. At the moment the car also has Ďsticky gearsí where the gear stick fails to self centre. Is this related to the warning light? Iím hoping that the Ďsticky gearsí simply need greasing up, but Iím worried in case running the car in its present state is damaging the engine.

Any help or reassurance would be appreciated.
StairyAlfa is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 8 Old 18-02-10 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2010
Location: United Kingdom
County: Leicestershire
Posts: 22
Anyone?
StairyAlfa is offline  
Status: 1750TBIecusoftware.. done!.40+bhp
AO Silver Member
 
ALFA TUNER's Avatar
 
Join Date: Jan 2009
Location: United Kingdom
County: Merseyside
Posts: 3,480

Member car:

various Alfas

The little light that looks like an engine is the engine management light.It will come on when you turn the ignition on ,then it will go off 3-4 seconds after you have started the engine and everything is ok.
ALFA TUNER is offline  
(Post Link) post #4 of 8 Old 18-02-10 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2010
Location: United Kingdom
County: Leicestershire
Posts: 22
ah cool, so my understanding of that is the engine management light is meant to stay on after all the others have gone off, only to go off itself when the engine has started.

Thanks for that. I’m finding this website and the people on it really helpful.
StairyAlfa is offline  
Status: Hey Joe...
AO Gold Member
 
iainfm's Avatar
 
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,274

Member car:

Jaaaaag

On the older ECUs, the corresponding light will go off prior to engine-start (assuming everything is ok).
iainfm is offline  
Status: One foot in, one foot out!
AO Platinum Member
 
zulu ferret's Avatar
 
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,278
What they said, and try not to worry too much? Drive and enjoy.
zulu ferret is offline  
Status: Still going strong.
AO Silver Member
 
armoore's Avatar
 
Join Date: Jan 2002
Location: United Kingdom
County: Surrey
Posts: 5,128
I've just cured the sticky gear lever on my daughter's 147 by taking the spindle and its mounting off from on top of the gearbox. I 'eased' the plastic bushes in the mounting with very smooth wet and dry and thoroughly cleaned the spindle. I then drilled the mounting to take a grease nipple to hopefully prevent the same in the future. Once it was all greased up again I re-assembled the spindle and then refitted it on top of the gearbox. If you do a search you'll find many threads on this subject. The mounting and spindle assembly is available if you just want to swap over and not bother with the cleaning up part. Try shop4parts, it is there on their site but not obviously so, or wasn't when I looked.
armoore is online now  
(Post Link) post #8 of 8 Old 18-02-10 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2010
Location: United Kingdom
County: Leicestershire
Posts: 22
Don’t get me wrong I am really enjoying the driving experience of the car. My last 3 cars (cars used in the loosest term of the word), have been small and French. They don’t even compare to an Alfa. I’m just keen to keep my car running good and resolve and issues quickly before they become a nightmare.

Cheers for all the posts about this.
StairyAlfa is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , ignition , light , mangement

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 14-08-19 13:36
Mito clover (and other Alfa propaganda) Toronto Spider General Alfa Discussion 4 10-09-09 09:14
alfa 156 tuning belfast bob Tuning & Upgrades 29 25-06-08 20:35
Which one is the best goldstud Tuning & Upgrades 17 24-06-08 11:50

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome