Where's the glow plug relay on a 1.9 16v JTD? (147) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 8 Old 04-01-10 Thread Starter
Status: Driving the Spider more than ever!
AO Member
 
cuttlefish's Avatar
 
Join Date: Feb 2008
Location: United Kingdom
County: Nottinghamshire
Posts: 821
Garage
Where's the glow plug relay on a 1.9 16v JTD? (147)

As the title says, any advice much appreciated!
cuttlefish is offline  
Sponsored Links
Advertisement
 
Status: To GTB or not to GTB?
AO Silver Member
 
TribesMan's Avatar
 
Join Date: Nov 2007
Location: Slovenia
County: -
Posts: 2,289
In the fuse/relay box in front of the battery?

But I have no idea which one is it. There is quite a few relays in there.
TribesMan is offline  
(Post Link) post #3 of 8 Old 04-01-10 Thread Starter
Status: Driving the Spider more than ever!
AO Member
 
cuttlefish's Avatar
 
Join Date: Feb 2008
Location: United Kingdom
County: Nottinghamshire
Posts: 821
Garage
Could it be the one labeled 'coil heater'? If only they simply called it the "glow plug relay"! Also, may sound a daft question but does a relay look like a large fuse, or is it one of the small black boxes/plug-type things? Cheers
cuttlefish is offline  
Status: To GTB or not to GTB?
AO Silver Member
 
TribesMan's Avatar
 
Join Date: Nov 2007
Location: Slovenia
County: -
Posts: 2,289
It could be coil heater, but JTDs also have additional electrical heater to warm the engine up faster when it is cold outside... so it could also mean that one.

Relays look like black boxes, with at least 4 contact pins on the bottom side.
TribesMan is offline  
Status: -
Guest
 
Join Date: Aug 2015
Location: Titchfield
County: -
Posts: 2

Member car:

147 ti

Hello

I have changed the glow plugs on my 147 but still get an error message. Advice is to change the glow plug relay. Had a look in the fuse box near battery and cannot see a relay (are they under the top tray??). Looking at the relays on the web they seem to be a different size to that in the fuse box. Help. Or am I missing something?
andrewhoare is offline  
Status: -
AO Silver Member
 
Join Date: Jun 2007
Location: United Kingdom
County: -
Posts: 1,168
Quote:
Originally Posted by andrewhoare View Post
Hello

I have changed the glow plugs on my 147 but still get an error message. Advice is to change the glow plug relay. Had a look in the fuse box near battery and cannot see a relay (are they under the top tray??). Looking at the relays on the web they seem to be a different size to that in the fuse box. Help. Or am I missing something?
I believe it is on the bulkhead near the power steering (?) reservoir.
gtv160 is offline  
Status: -
Newbie
 
Andrew Hoare's Avatar
 
Join Date: Aug 2015
Location: Titchfield
County: Hampshire
Posts: 2

Member car:

Alfa 147 Ti

Many thanks
Andrew Hoare is offline  
Status: -
Newbie
 
Andrew Hoare's Avatar
 
Join Date: Aug 2015
Location: Titchfield
County: Hampshire
Posts: 2

Member car:

Alfa 147 Ti

I have changed the glow plugs and now the relay but still get the error message...... read somewhere that it takes a few miles for the relay to 'settle down' is this true? Not sure what to fix next..

Baffled again!
Andrew Hoare is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
147 , 16v , glow , jtd , plug , relay

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 14-08-19 13:36
So how many and where are the GTA's ??? 156GTASW Alfa GTA 608 27-10-11 09:11

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome