noisy top end and no power - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 03-01-10 Thread Starter
Status: back out of love with my145
AO Member
 
addamski1980's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Cornwall
Posts: 182

Member car:

Gt JTD

noisy top end and no power

was driving my 145 cloey when a noise started to come from the engine and then a loss of power i pulled over and got towed home. ive took the rocker cover of and could see the timing belt was still tensioned across cam pulley's. i was thinkling it might of dropped a valve
was just wondering if anyone else has any ideas what it could be.
addamski1980 is offline  
Sponsored Links
Advertisement
 
Status: zzzzzzzz
AO Platinum Member
 
symon's Avatar
 
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 37,076
What sort of conditions are the cam lobes in?

Also check all of the spark plugs are tight. If one is loose the car will sound like a tractor and only run on 3 cylinders.

I have had one eject itself from the head on a TS before now after a previous owner damaged the thread.
symon is offline  
(Post Link) post #3 of 3 Old 03-01-10 Thread Starter
Status: back out of love with my145
AO Member
 
addamski1980's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Cornwall
Posts: 182

Member car:

Gt JTD

plugs are tight lobes look alright but cant see some as they are on hydraulic tapits. ive gotta do variator so when the cam is out will inspect all of it and probably take head off too have a look at valves. im gonna fix it because i love the car so much but she is becoming a bit of a money pit.
addamski1980 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
end , noisy , power , top

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome