2.4 JTDm cold starts - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 03-11-09 Thread Starter
Status: happy!!
AO Silver Member
 
AlexT's Avatar
 
Join Date: Oct 2009
Location: United Kingdom
County: Buckinghamshire
Posts: 1,327
2.4 JTDm cold starts

how are yours fellows?
After a chilly night my car will almost always sound like only 3 cylinders are going at startup, but give it a few secs and it'll get regular. Is it just me? I thought it was a matter of glow plugs, but they've been changed (allegedly..).

A.
AlexT is offline  
Sponsored Links
Advertisement
 
Status: playing kill by numbers
AO Gold Member
 
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 8,786
try starting for half a second longer.....
Cuore_Sportivo_155 is offline  
Status: waiting for home-time...
AO Member
 
Join Date: Sep 2009
Location: United Kingdom
County: Merseyside
Posts: 40

Member car:

Brera 2.4M

Quote:
Originally Posted by Cuore_Sportivo_155 View Post
try starting for half a second longer.....
we have starter buttons on the brera dude, no can do... i have noticed this, when i first got mine. try using vpower diesel ?
pabb85 is offline  
Status: Feeling lonely
 
RomeoRaiderZ's Avatar
 
Join Date: Jan 2008
Location: United Kingdom
County: West Lothian
Posts: 3,506
Garage
Are you getting smoke too Alex, like I was? https://www.alfaowner.com/Forum/alfa-...-to-smoke.html
RomeoRaiderZ is offline  
(Post Link) post #5 of 6 Old 06-11-09 Thread Starter
Status: happy!!
AO Silver Member
 
AlexT's Avatar
 
Join Date: Oct 2009
Location: United Kingdom
County: Buckinghamshire
Posts: 1,327
Hi romeorider! Apart for the smoke thing i have EXACTLY the same symptoms! How did u sort yours eventually?
AlexT is offline  
Status: Feeling lonely
 
RomeoRaiderZ's Avatar
 
Join Date: Jan 2008
Location: United Kingdom
County: West Lothian
Posts: 3,506
Garage
Quote:
Originally Posted by AlexT View Post
Hi romeorider! Apart for the smoke thing i have EXACTLY the same symptoms! How did u sort yours eventually?
5 new injectors (£3k's worth, ) under warranty cured it for a bit, but it's started doing it again, , on occasions now that the frosts have arrived, . Although the dealer assures me that the glowplugs are OK, I'm still not totally convinced (the glowplug light goes out almost immediately when you insert the fob) so I think I might have them changed anyway for all they cost (assuming they are non-warranty).
RomeoRaiderZ is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
cold , jtdm , starts

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome