HELP engine / turbo problem 1.9 jtd - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 28-10-09 Thread Starter
Status: -
 
Join Date: Jun 2008
Posts: 19
HELP engine / turbo problem 1.9 jtd

Hi, could do with some help please.

Driving on the motorway yesterday, major power loss from engine, accompanied with blue/black smoke, couldnt get over 2000rpm and no turbo kicking in.

It sounds as though it could be a split hose from intercooler to turbo, like many other threads have stated, which would be good, BUT.

The engine drank 5 litres of oil in 25 miles, driving very gently & there is oil inside the top hose from intercooler to throttle control.

would a split hose from intercooler to turbo cause a serious loss of oil, theres nothing underneath car, its all being burned through engine.

Any suggestions, a buggered turbo or split hose or seals/bearings?

any help would be most appreciated.
thanks
tritont40 is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Feb 2005
Location: Benfleet, Essex
Posts: 37

Member car:

Guilia Super

Ouch...! sound like the turbo seals/bearings have given up..the oil would be pushed through the inlet tract/pipework from the turbo, resulting in massive oil usage, no spin-up, therefore no oomphf...
If you are mechanically minded you could remove the unit and have it checked/overhauled by an engine shop..OR.. look for a mechanic who knows what they are doing...
I`d happily offer my services....i`m based in South East Essex...Where are you..?
Mark....Italian Race Services
Spudulike1 is offline  
(Post Link) post #3 of 3 Old 28-10-09 Thread Starter
Status: -
 
Join Date: Jun 2008
Posts: 19
thanks,

that was my worst fear, i will remove the offending unit. i work in carlisle but live near glasgow.

al
tritont40 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , jtd , problem , turbo

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 14-08-19 13:36
GT 1.9 JTD Engine Problem moyletra Alfa 147, 156 & GT 31 19-11-09 12:39
Mito clover (and other Alfa propaganda) Toronto Spider General Alfa Discussion 4 10-09-09 09:14

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome