gtv engine mount change but no better!!!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 5 Old 18-10-09 Thread Starter
Status: -
Newbie
 
Join Date: Jun 2007
Location: bottesford ,lincs
Posts: 6
gtv engine mount change but no better!!!!!

Hi everyone, i have read all the posts and taken alot of advice. I have had major problems with a knocking and vibration through the master brake. when the engine moves it has cut into the injector intake! when setting off i can feel the knocking through the pedals and it also sounds loud, I have changed all mounts on the car and new arms plus all anti roll bar bushes. the top mount didnt have any washers, would that make any change. please help me ?????????
diovisalvi is offline  
Sponsored Links
Advertisement
 
Status: faclifting a 156
AO Silver Member
 
biffa's Avatar
 
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
Did you change the bottom one that supports the gearbox?
biffa is offline  
(Post Link) post #3 of 5 Old 29-10-09 Thread Starter
Status: -
Newbie
 
Join Date: Jun 2007
Location: bottesford ,lincs
Posts: 6
hi thanks for looking at my problem, i put a used one on last year but i am not able to find a new one? can you help. would that make the engine rock alot ?
diovisalvi is offline  
Status: faclifting a 156
AO Silver Member
 
biffa's Avatar
 
Join Date: Oct 2006
Location: United Kingdom
County: Lancashire
Posts: 3,199
It would make it bang more so when changing gear...

Have you tried Ned/Dan at Autolusso (do a forum search for autolusso)
biffa is offline  
Status: #keepFightingMichael
AO Gold Member
 
EauRouge's Avatar
 
Join Date: Jun 2009
Location: Suriname
County: Brokopondo
Posts: 7,721
sorry divo i mean! is yours a twinnie? The support at top of engine, if we are talking about the same thing looks like a bone and is bolted at top left as you look from engine bay!

Well, by no washers do you mean... no rubber bushes?

Last edited by EauRouge; 29-10-09 at 23:03. Reason: wrong person!
EauRouge is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
change , engine , gtv , mount

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 14-08-19 13:36
Mito clover (and other Alfa propaganda) Toronto Spider General Alfa Discussion 4 10-09-09 09:14
Which one is the best goldstud Tuning & Upgrades 17 24-06-08 11:50

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome