Help. No spark. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 10 Old 12-09-09 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2009
Location: United Kingdom
County: Suffolk
Posts: 35

Member car:

156 SportWagon

Help. No spark.

Hi.

Car is 156 2.0 TS. 2001(y) sportwagon.

story so far...
I bought this as a non runner with a failed engine (bottom end).
Removed engine and found a used unit from a smashed car which supposedly had done only 40000 miles. Upon receipt of engine noticed it was a CF2 and not a CF3. Was advised this would be ok as long as i used my original engine loom and ecu, etc...swap all parts over to new engine, also fitted new belts, big ends, clutch etc...seemed silly not too!
Fitted new engine.
Tryed to fire up today with no joy. Turns over ok, getting fuel, but NO spark!
Key code light does go out when cranking.

Any ideas?
YODABOY is offline  
Sponsored Links
Advertisement
 
Status: Rebuilding series 3 landy, nearly there!
AO Member
 
UKSPF's Avatar
 
Join Date: Nov 2008
Location: United Kingdom
County: Torfaen
Posts: 299

Member car:

145 Cloverleaf

Crank sensor.
UKSPF is offline  
Status: Busy busy busy!
Club Member
Membro Premio
 
Pud237's Avatar
 
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 44,901
Key code light should go out after a couple of seconds of turning the key to the MAR position, cranking or not.

There's probably an issue with the electronics, possibly crank sensor, but also check the earth on the coil packs.
Pud237 is offline  
(Post Link) post #4 of 10 Old 12-09-09 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2009
Location: United Kingdom
County: Suffolk
Posts: 35

Member car:

156 SportWagon

can you check/test the crank sensor with a meter?

Cheers.
YODABOY is offline  
Status: Rebuilding series 3 landy, nearly there!
AO Member
 
UKSPF's Avatar
 
Join Date: Nov 2008
Location: United Kingdom
County: Torfaen
Posts: 299

Member car:

145 Cloverleaf

Possible, I'd have a look on autodata but im not at work at the moment.
UKSPF is offline  
Status: Rebuilding series 3 landy, nearly there!
AO Member
 
UKSPF's Avatar
 
Join Date: Nov 2008
Location: United Kingdom
County: Torfaen
Posts: 299

Member car:

145 Cloverleaf

Yep you can test them, with component disconnected. Resistance across both terminals should be between 784-965 ohms, typically.
UKSPF is offline  
(Post Link) post #7 of 10 Old 14-09-09 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2009
Location: United Kingdom
County: Suffolk
Posts: 35

Member car:

156 SportWagon

cheers.

Yeah mine reads 0.00. I have another which reads 900. wil fit this and try.

thanks again.
YODABOY is offline  
(Post Link) post #8 of 10 Old 16-09-09 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2009
Location: United Kingdom
County: Suffolk
Posts: 35

Member car:

156 SportWagon

fitted the crank sensor of my old engine and BINGO! she's a runner. I will sleep well tonight!

cheers for the help.
YODABOY is offline  
Status: -
AO Platinum Member
 
Ralf S.'s Avatar
 
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 13,124
Nice one! Well done for letting us know what fixed it too.. quite often the OP "disappears" and nobody knows if the last suggestion worked or not.

Ralf S.
Ralf S. is offline  
Status: Rebuilding series 3 landy, nearly there!
AO Member
 
UKSPF's Avatar
 
Join Date: Nov 2008
Location: United Kingdom
County: Torfaen
Posts: 299

Member car:

145 Cloverleaf

Great that it worked, it is common for people to overlook the crank sensor, but it is always the first place I go with a non starting alfa.
UKSPF is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
spark

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
156 v6 2.5 spark plugs bruzza Alfa 147, 156 & GT 13 31-08-09 12:27
Spark plugs yeroulfella Tuning & Upgrades 4 18-07-08 19:09
156 V6 Spark Plugs ? What Make ? top_man_eldo Alfa 147, 156 & GT 5 16-03-08 22:31
general car information, oils, tyres etc. armoore Way Off Topic 9 26-09-06 15:27
Spark Plugs BUFFY FAN Alfa 147, 156 & GT 5 23-03-06 16:05

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome