HELP engine oil pressure low - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 16 Old 30-08-09 Thread Starter
Status: -
 
Join Date: Jan 2009
Posts: 29
HELP engine oil pressure low

i keep getting engine oil pressure low when im comin to a stand still or in traffic after driving like 2 miles , or roughly when the cars warmed up , i dont have any leaks i dont think either ,
what are possible causes , please help
leahgt is offline  
Sponsored Links
Advertisement
 
mudhut
Status: - Update
Guest
 
Posts: n/a
Not sure I can give you any definitive information, but you will need to say what engine you have, what rpm and what oil pressure you think is possibly low.

By low, do you mean that the oil pressure warning light is on (or do you have a pressure gauge)?

Last edited by mudhut; 30-08-09 at 13:38.
 
0of0
Status: - Update
Guest
 
Posts: n/a
Has the oil level been checked?
 
(Post Link) post #4 of 16 Old 30-08-09 Thread Starter
Status: -
 
Join Date: Jan 2009
Posts: 29
engine is 2.0 jts selespeed , it only happenswhen im comin to a slow or stationary in traffic as soon as i start back off it goes off , oil levels are all perfect ,

engine oil pressure low
leahgt is offline  
gazza12345
Status: - Update
Guest
 
Posts: n/a
I had this with my 147, the warning would come on after i stalled or went around a corner very fast, never caused any problems though and the oil was on the top dot all the time.
 
Status: Waiting for Spiderweather
AO Member
 
luckydog's Avatar
 
Join Date: Jun 2009
Location: United Kingdom
County: Suffolk
Posts: 212
Quote:
Originally Posted by leahgt View Post
i keep getting engine oil pressure low when im comin to a stand still or in traffic after driving like 2 miles , or roughly when the cars warmed up , i dont have any leaks i dont think either ,
what are possible causes , please help
I would be wary about continuing driving with this fault.
The fact that the oil level is good leads me to suspect that there is a pressure problem. This along with the fact that it happens when engine is warmed up (oil less viscous) and when coming to a stop (oil pump not rotating quickly) points to an internal engine problem that should be investigated.
luckydog is offline  
(Post Link) post #7 of 16 Old 03-09-09 Thread Starter
Status: -
 
Join Date: Jan 2009
Posts: 29
ican turn engine off now leave it 20 secs and lights gone , till i drive off and slow down again
leahgt is offline  
Status: -
Unregistered
 
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
The oil pressure switches are renowned for being fauty in the TS and JTS, Switches are cheap and easy to change so don't fret too much.
Smaky is offline  
Status: -
AO Platinum Member
 
Ralf S.'s Avatar
 
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 13,105
Aye! Stick a new pressure switch in there and that will probably solve it. My '55 is on its third sender.. they seem to get bunged up over time and start reading lower than they should when the pressure dips temporarily.


Ralf S.
Ralf S. is offline  
Status: -
AO Silver Member
 
oilman's Avatar
 
Join Date: Aug 2004
Location: United Kingdom
County: Cornwall
Posts: 1,111

Member car:

147

What oil are you using in it?

Cheers

Guy
oilman is offline  
Status: -
AO Platinum Member
 
Ralf S.'s Avatar
 
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 13,105
Who, me? I run semi-synthetic 10W40 and leave it in there for the full-monty 12,000 miles service interval.

I've used Selenia, Shell Helix, Castrol and even the Big H. green can stuff. When I fixed the head gasket I noticed all sorts of gum and varnish in there... nothing tooooo serious but it looked not very nice, so I nuked it with kerosene and then filled the beast up with Halfords 10W40 semi-synthetic for Diesel engines, as it's got more detergent in it. That flushed out a fair bit of post-rebuild black stuff and motor looks pretty clean in there still.

It's using 15W40 at the moment, as I just been down to Italia on the autostrada (engine oil touching 98C for extended periods, so I wanted as much viscosity as I dared).

Next change (next week) should be back to 10W40 as it's winter soon. Got half a can of Halfords green... so may use that, or I may spoil the beast and buy some synthetic Motul 6100 (?) for it.. as the syntho' stuff has more detergents in it than semi-synth. Need to find a 25 ltr drum though.. the 4ltr cans makes it an expensive hobby otherwise.

I don't want to change the oil more than 12,000 miles though... my engine wear is miniscule (even with 200,000m up) so apart from the gum/varnish issue, the 12,000 oil mileage isn't causing any problems.



Ralf S.

No bullets for Chaingun..

Last edited by Ralf S.; 15-09-09 at 14:37.
Ralf S. is offline  
Status: -
AO Silver Member
 
oilman's Avatar
 
Join Date: Aug 2004
Location: United Kingdom
County: Cornwall
Posts: 1,111

Member car:

147

Ralf,

Sorry, I mean the OP.

The Motul 6100 is still mineral based, if you really want to treat it give it a full synthetic.

Cheers

Guy
oilman is offline  
Status: -
Newbie
 
Join Date: Sep 2009
Location: United Kingdom
County: Tyne and Wear
Posts: 7
Quote:
Originally Posted by gazza12345 View Post
I had this with my 147, the warning would come on after i stalled or went around a corner very fast, never caused any problems though and the oil was on the top dot all the time.
mine just did this today,
i went round a roundabout fairly quick and the display beeped and said oil pressure low,
the level is spot on,

only had car a month, hope it's ok,
alfanatt is offline  
Status: Busy busy busy!
Club Member
Membro Premio
 
Pud237's Avatar
 
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 44,874
Quote:
Originally Posted by alfanatt View Post
mine just did this today,
i went round a roundabout fairly quick and the display beeped and said oil pressure low,
the level is spot on,

only had car a month, hope it's ok,
What oil is in it?
Pud237 is offline  
0of0
Status: - Update
Guest
 
Posts: n/a
Why is the OP now unregistered it's one thing to not follow up on a thread, but another to delete your account
 
Status: -
Newbie
 
Join Date: Sep 2009
Location: United Kingdom
County: Tyne and Wear
Posts: 7
Quote:
Originally Posted by Pud237 View Post
What oil is in it?
i think i stuck 10/40 semi in it,
what would you recommend?
viscosity and make,
alfanatt is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , low , oil , pressure

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2.4 jtd flatspot bruce Alfa 147, 156 & GT 31 11-05-08 09:08
Oil labelling explained oilman Alfa 147, 156 & GT 10 29-11-06 11:57
greased lightening? alfapersius General Alfa Discussion 14 19-09-06 16:25
Engine Oil pressure low Zahir Alfa 145 & 146 7 31-08-06 19:05
Alfa 147 - Low engine oil pressure warning at idle, HELP!!! weasel Introduce Yourself 1 31-07-06 22:22

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome