HELP brera engine problems and codes - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 11 Old 27-08-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 22
HELP brera engine problems and codes

It started with the car making a noise like the air con system was playing up. Took to dealers who said they couldn't find a problem. 1 month later and warrenty run out engine managment light keeps coming on and car goes into safe mode with dramatic loss of power. Alfa has said the codes are p2313, p2013, p111 and have produced a list of parts as long as your arm. They have said 1100 in parts and 900 to fit. But they can't/won't explain the problem.
Can any one explain the codes and give some advise as alfa won't due to warrenty expired.

Need some help please!!!

Ps on a positive note the noise has nearly stoped.
Pikey74 is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Lotkie's Avatar
 
Join Date: Aug 2009
Location: Ireland
County: Galway
Posts: 20

Member car:

alfa 147 JTD 16V

What engine have you got there?
Lotkie is offline  
(Post Link) post #3 of 11 Old 28-08-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 22
2.4 diesel turbo
Pikey74 is offline  
Status: -
AO Member
 
Lotkie's Avatar
 
Join Date: Aug 2009
Location: Ireland
County: Galway
Posts: 20

Member car:

alfa 147 JTD 16V

p2013 - Intake manifold air control actuator, bank 2 circuit high, - wiring can be short to positive or maybe actuator needs a little bit of cleaning.

p2313 - again check wiring and coil E

p111 - check air intake temperature sensor (IAT)

Hope this helps...
Lotkie is offline  
(Post Link) post #5 of 11 Old 31-08-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 22
thank you!! really helpfull. gonna speak to simply alfa tomorrow who think they can help now i have given them your information.

Stress!!

thanks again for your help. the dealership wanted to change a list of parts as long as your arm and charge me 2k for parts and labour.
Pikey74 is offline  
Status: -
Newbie
 
Join Date: Jan 2009
Location: Portugal
County: Lisboa
Posts: 6

Member car:

brera

Getting P0016? Help!

i've a brera 2.2 from 2006. for the last 10 months i'm getting the engine light always on and everytime i start the car i also get the engine warning.

Im from Portugal and i've been in almost all alfa romeo mechanics and nobody gives me the solution,. they all erase the error, reset the system and try to charge but it just lasts a couple of hours.
The error is the P0016?anyone knows how to solve the *****??
help me guys
thnks alfistas
b4ro is offline  
Status: 1750TBIecusoftware.. done!.40+bhp
AO Silver Member
 
ALFA TUNER's Avatar
 
Join Date: Jan 2009
Location: United Kingdom
County: Merseyside
Posts: 3,480

Member car:

various Alfas

It indicates misstiming between cam and crank sensors,take to the dealers and check the timing chain!!
ALFA TUNER is offline  
(Post Link) post #8 of 11 Old 15-09-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 22
I've been told that on your model the chain gets stretched so might need to replace it. Simplyalfa have fixed my problem now. Dealers wanted 2100 simplyalfas done for 793.
Pikey74 is offline  
Status: -
 
Join Date: Mar 2009
Posts: 1
I have been suffering a recurring P2013 error, The local dealer cleaned a valve, charged me 145, and the problem went away.....briefly

From what I have read on the forum, the solution seemd to be a replacement of the inlet manifold. Have I understood this correctly.

I was wondering if anyone could give me an idea of prices for having this work done. As the car is now out of warranty, I am loathed to pay dealer prices.
Daisyroots is offline  
(Post Link) post #10 of 11 Old 18-09-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 22
I changed manifold gaskits & cam belt and they cleaned out e..? Value 793 car drives fine again now. Speak to simplyalfas. They were the cheapest I could fine & they do no what there talking about. If you give them a call there more than happy to have a chat about it.
Pikey74 is offline  
Status: -
AO Member
 
Join Date: Nov 2004
Location: Peru
County: Lima
Posts: 18
Hi, I am from Peru, I read in this post about P0016 error and how solve it. I got an 159 2.2 from 2007 with the same problem. Following the Alfa dealer instructions We changed the 2 electro valves in the engine but light engine keep on, I asked them about check timing chain but it did not solve the problem. I know the dealer have the same problem with a Brera 2.2 too, can you help me?
rjbvargas is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
brera , codes , engine , problems

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome