Major Issue with T Spark Engine - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 14 Old 26-08-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 15
Major Issue with T Spark Engine

Hi there first post

I bought a 2.0 16v T Spark 5 days ago all was well until this morning i drove to my place work and all was well it was not until the journey home that there was a really bad knocking noise when i put my foot down on the throttle it was only there at low revs and dissapeared at high revs. the knocking sound was running in time with the engine? Im unsure of what this is, it still drives but i have to take it really easy as if not the horrible noise comes back when i give to much throttle.

Many thanks in advance
Jamesuktspark is offline  
Sponsored Links
Advertisement
 
Status: One foot in, one foot out!
AO Platinum Member
 
zulu ferret's Avatar
 
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,278
Sounds expensive. Have you checked the engine oil level? Could be big end bearing problems. :
zulu ferret is offline  
(Post Link) post #3 of 14 Old 26-08-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 15
Big End problem is what im thinking im also concerned it could be the cam lifters, oil level is fine as area the other levels, the car does not get warm any different than usual. Obviousely the name Big End sounds seriouse enough is it a big problem would it mean a new engine or can it be repaired?
Jamesuktspark is offline  
0of0
Status: - Update
Guest
 
Posts: n/a
Is there a service history? - could be the result of a cambelt snap, head rebuild & the bottom end not getting new shells - this could have happened a few thousand miles ago though - as said low oil level can also lead to this
 
(Post Link) post #5 of 14 Old 26-08-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 15
cam belt replaced at 105236 miles and current mileage is 110374
Jamesuktspark is offline  
(Post Link) post #6 of 14 Old 26-08-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 15
full service history as far back as mileage 42000
Jamesuktspark is offline  
Status: Always working
Identity Confirmed
Authorised Trader
 
Autolusso's Avatar
 
Join Date: Feb 2007
Location: United Kingdom
County: Bedfordshire
Posts: 7,038
Quote:
Originally Posted by Jamesuktspark View Post
cam belt replaced at 105236 miles and current mileage is 110374
Needs an engine rebuild, when the belt was changed at 105k it was probably due to a belt failure and now the damage to the bottom end is becoming apparent.

There is a bit on our web site about this

Auto Lusso - Alfa Romeo Engine Rebuilds, Replacement and Repairs - Hertfordshire, Bedfordshre UK

We can also supply a second hand engine

Ned
Autolusso is offline  
(Post Link) post #8 of 14 Old 26-08-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 15
Ned how much we looking at if it comes to it for a new engine and fitting a rough cost?
Jamesuktspark is offline  
(Post Link) post #9 of 14 Old 26-08-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 15
prices seen on site thanks will keep you in mind once i get a result to the matter
Jamesuktspark is offline  
Status: Waiting for Spiderweather
AO Member
 
luckydog's Avatar
 
Join Date: Jun 2009
Location: United Kingdom
County: Suffolk
Posts: 212
Where are you in Norfolk? I ask because theres a chap selling a 2.0 twinnie engine at Wymondham.
Just a thought.
luckydog is offline  
(Post Link) post #11 of 14 Old 27-08-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 15
hello yes im located in norwich norfolk would be great to get some news on pricing for the twinnie thanks
Jamesuktspark is offline  
Status: Waiting for Spiderweather
AO Member
 
luckydog's Avatar
 
Join Date: Jun 2009
Location: United Kingdom
County: Suffolk
Posts: 212
Quote:
Originally Posted by Jamesuktspark View Post
hello yes im located in norwich norfolk would be great to get some news on pricing for the twinnie thanks
pm sent
luckydog is offline  
(Post Link) post #13 of 14 Old 27-08-09 Thread Starter
Status: -
 
Join Date: Aug 2009
Posts: 15
luckydog thanks for the info, im taking the car to an alfa garage in norwich on beech road on saturday to see what they think will keep you all posted and fingers crossed its not bad
Jamesuktspark is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,115
Garage
Sounds like bottom end. Had the same problem. Don't drive it as you may be able to just put some shells in it and get the crank reground. Driving it increases the chance of putting a rod through the block!
Joss is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , issue , major , spark

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 14-08-19 13:36
16 important OIL questions and answers oilman Alfa 147, 156 & GT 339 03-06-18 10:39
alfa 156 tuning belfast bob Tuning & Upgrades 29 25-06-08 20:35
Which one is the best goldstud Tuning & Upgrades 17 24-06-08 11:50
155 8v TWIN SPARK Engine Explode ! Avantz155 Engines (TS, JTS, JTD & V6) 6 11-09-07 06:48

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome