Assistance S.Wales - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 14-08-09 Thread Starter
Status: -
AO Member
 
cincity's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Wales
Posts: 21

Member car:

159 sw Ti

Assistance S.Wales

Anyone got recomendations for reputable, honest, reliable, helpful diagnostic and repair centre around the Newport/Blackwood area of S.Wales pls?
Or is this a big ask for 'garages'?
cincity is offline  
Sponsored Links
Advertisement
 
Status: Misunderstood by many....
AO Platinum Member
 
n13roy's Avatar
 
Join Date: Feb 2008
Location: South Wales
Posts: 28,482

Member car:

147 JTDm Ti

There are a few folks from that area on here, why not pop into the Welsh thread and leave a comment / question there.......
n13roy is offline  
Status: Misunderstood by many....
AO Platinum Member
 
n13roy's Avatar
 
Join Date: Feb 2008
Location: South Wales
Posts: 28,482

Member car:

147 JTDm Ti

Actually I think there is a thread on here about Dealers in South Wales etc.etc....




https://www.alfaowner.com/Forum/wales...uth-wales.html





......Hope that helps.........

Last edited by n13roy; 14-08-09 at 11:46.
n13roy is offline  
(Post Link) post #4 of 6 Old 14-08-09 Thread Starter
Status: -
AO Member
 
cincity's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Wales
Posts: 21

Member car:

159 sw Ti

Yeh, thanks. I found that thread about 2 mins after posting this string.
The car is booked into Newport later next week - I am (my cheque book is) dreading the labour charges.

I have put the problems that are being experienced on other strings here (the 147 pages)- will update as I know more.
cincity is offline  
Status: Hey Joe...
AO Gold Member
 
iainfm's Avatar
 
Join Date: May 2008
Location: United Kingdom
County: Perth and Kinross
Posts: 6,274

Member car:

Jaaaaag

What problems are you having?
iainfm is offline  
(Post Link) post #6 of 6 Old 14-08-09 Thread Starter
Status: -
AO Member
 
cincity's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Wales
Posts: 21

Member car:

159 sw Ti

i will try to be brief - it started with massive loss of power, had maf and egr replaced and £460 bill. That then gave me idling issues and problems at constant speed 'hickups' at <2k revs, but performance, fuel economy and acceleration were ok. That garage suggested getting injectors tested at £30 each with no guarantees. So I took the car back and then got engine management alarm. Have had the management alarm reset but still got idling problems. The error codes are pointing to injection system issues - I dont have the codes. Whilst idling, the car starts to smoke (white/grey) after about 20-30 seconds, and it smells diesel(ish). My mate (different independant garage) doesnt know what to do to fix idling issues so i have booked it in to fiat dealer in newport.
I hope that info helps.
cincity is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
assistance , swales

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome