147 JTD 16v idling problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 15 Old 14-08-09 Thread Starter
Status: -
AO Member
 
cincity's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Wales
Posts: 21

Member car:

159 sw Ti

147 JTD 16v idling problems

Hi all.

I have just had my MAF and EGR replaced, along with a rather hefty bill, and the car now accelerated fine, and will run ok at a constant speed in any gear over 2k revs. However, at less revs and whilst idling it feels as if the timing is off or its running on 3 cylinders. Oh, and it smokes a lot when left idling.

My engine management light has come on but has since been cleared and I am going to put a new battery on it - just to be sure. My mate (mechanic) recommends scrapping it but I really dont want to do that, and another garage recommends getting the injectors checked.
Personally, I dont think it is the injectors as this has been a sudden decline after the replacement of the EGR and MAF sensors.

Any ideas?
Thx in advance.
cincity is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 15 Old 14-08-09 Thread Starter
Status: -
AO Member
 
cincity's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Wales
Posts: 21

Member car:

159 sw Ti

Additionally, when it does smoke, it is white not black.

Could this be a lambda sensor issue? If so, front, back, or both?
cincity is offline  
Status: -
AO Silver Member
 
typos1's Avatar
 
Join Date: Mar 2008
Location: United Kingdom
County: Dorset
Posts: 3,789

Member car:

147 Ducati Corse

Ignore your mate-you dont scrap a relatively new car cos theres a bit of smoke!

Wont be a lambda prob-you dont have any. Diesels only have lambda sensors if theyve got DPF. Only the 1.9 in the 159 has DPF currently.

Does the idle speed need adjusting?-Whats it idling at? Should be 850-950 rpm
typos1 is offline  
(Post Link) post #4 of 15 Old 14-08-09 Thread Starter
Status: -
AO Member
 
cincity's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Wales
Posts: 21

Member car:

159 sw Ti

It idles at the correct speed but after about 20-30 seconds starts to hunt, or sounds as if it is missfiring. At this point it starts to smoke. The longher it is left to idle the worse the hunting gets. but it does not cut-out.
The smoke is white/greyish and smells quite strongly - I wouldnt describe it as a diesel smell (not exactly).
There is no sign of water in the oil.
I have driven it today for about 20 miles - it performs when accelerating, other than a bit of smoke.
It has done 106k miles.
The engine control failure has been cleared and has not yet come back on.
cincity is offline  
Status: -
AO Member
 
Join Date: Jun 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 59

Member car:

escort van

Hi mate,
I would have a proper leak test done as it could be a head gasket, dont always get the milky crap in water dependant on where it's leaking.
A proper test where they test to see if coolant changes colour is needed mate...even just to eliminate the head gasket... hope ya sort it..



steve
sr-performance is offline  
Status: live and let live!!!
AO Member
 
dhillon's Avatar
 
Join Date: Oct 2006
Location: Sheffield
Posts: 726
Put some injector cleaner through the fuel system change the diesel filter - use a decent fuel cleaner such as millers and make sure you use decent quality fuel not supermarker crap
dhillon is offline  
Status: -
AO Silver Member
 
typos1's Avatar
 
Join Date: Mar 2008
Location: United Kingdom
County: Dorset
Posts: 3,789

Member car:

147 Ducati Corse

Lol, supermarkets buy their fuel from the major oil companies, its NOT crap, its the same
typos1 is offline  
Status: -
AO Member
 
Join Date: Jun 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 59

Member car:

escort van

It's not the same as supermarkets are allowed to put 5% bio crap in it!!!


steve
sr-performance is offline  
Status: -
AO Silver Member
 
typos1's Avatar
 
Join Date: Mar 2008
Location: United Kingdom
County: Dorset
Posts: 3,789

Member car:

147 Ducati Corse

All fuel companies are allowed to use bio.

They put it in all fuel in Europe.

Its not crap at all, in fact quite the opposite, not only is E85 ethanol cleaner burning you get slightly more power.

As well as being cleaner burning, diesel fuel with 5% veg oil has better fuel system lubricating properties than "dino" diesel.
typos1 is offline  
Status: -
AO Platinum Member
 
Ralf S.'s Avatar
 
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 13,105
Aye! It sounds like head gasket maybe. The hesitation is a bit of coolant damping the combustion process.

Check the header tank coolant level and look for air in the radiator.


Ralf S.
Ralf S. is offline  
Status: live and let live!!!
AO Member
 
dhillon's Avatar
 
Join Date: Oct 2006
Location: Sheffield
Posts: 726
The additive package is different in supermarket fuels, basic fuel is same, it is the addtive package which cleans your injectors and lubricates the fuel pump etc, etc!
dhillon is offline  
Status: -
AO Silver Member
 
typos1's Avatar
 
Join Date: Mar 2008
Location: United Kingdom
County: Dorset
Posts: 3,789

Member car:

147 Ducati Corse

I disagree. Additives vary between oil companies-they all use differeing amounts of differing additives, but all fuel has additives and all is good quality.

Youve just fallen for the oil companies marketing flanel, designed to get you to spend more on their fuel and put you off buying it from supermarkets-its all pretty much the same
typos1 is offline  
(Post Link) post #13 of 15 Old 20-08-09 Thread Starter
Status: -
AO Member
 
cincity's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Wales
Posts: 21

Member car:

159 sw Ti

Thx 4 all of ur advice.

No signs of water loss,
a sensor change,
and some diagnosis with no error codes.....
Resulting in another bill 4 £280,
Oh, and it is still exactly the same as it was. -- Well, at least I have a new sensor.

In fairness to the Garage - they were excellent - and the Mito courtesy car was a bonus. I will do a 'comparison in another thread, i am sure there are a few on here. The question is 'Am I going to be a Mito basher or not?'!!

So, after all that I am going to try a fuel system cleaner on the weekend and see how that goes.
FYI, I put approx £60 per week of supermarket fuel in it, so it could be gunked up. If the fuel cleaner doesnt work then I am going to have to try the injectors - more £££.
cincity is offline  
Status: -
AO Silver Member
 
typos1's Avatar
 
Join Date: Mar 2008
Location: United Kingdom
County: Dorset
Posts: 3,789

Member car:

147 Ducati Corse

300 quid for changing a sensor! Thats a rip off.

How can the garage be "excellent" if they charged you 300 quid and the car is no different?

This sort of thing is why I only ever use a main stealer if thats the only place I can get the parts from and nothing secondhand is available. Try using a decent independent specialsist-you ll save yourself a packet and probably get better service.

It wont be gunked up if you use supermarket fuel, thats marketing rubbish designed to make you pay more and buy from the major oil companies.
typos1 is offline  
(Post Link) post #15 of 15 Old 21-08-09 Thread Starter
Status: -
AO Member
 
cincity's Avatar
 
Join Date: Aug 2009
Location: United Kingdom
County: Wales
Posts: 21

Member car:

159 sw Ti

i wont give a breakdown of teh work but because of the changed air pressure sensor cleared all of the fault codes so a lot of time was spent checking seals, air pressures thro the system, a bit of fuel and a new air filter.
As ther are no error codes the next steps are by process of elimination - apparently.
Having said all of that, the engine management light came on again 2 miles from home this evening

I am stumped, skint, and frustrated. And trying not to be annoyed.
cincity is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
147 , 16v , idling , jtd , problems

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
So how many and where are the GTA's ??? 156GTASW Alfa GTA 608 27-10-11 09:11

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome