brake pedal / brake fluid prob? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 1 Old 30-06-09 Thread Starter
Status: -
AO Member
 
alfajts2's Avatar
 
Join Date: Jun 2006
Location: United Kingdom
County: Surrey
Posts: 297

Member car:

Alfa GT 2.0 JTS

Hmmm brake pedal / brake fluid prob?

Forget the type of car & the engine, what is thought of this? With car started but not even moving the brake pedal is juddery at the top of the pedal, brakes work ok. But with warmer weather or just after the brakes are bled(goes off after a week or so) the brake pedal improves to normal. Whats the problem?

Last edited by alfajts2; 30-06-09 at 22:56. Reason: bad spell
alfajts2 is offline  
Sponsored Links
Advertisement
 
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
brake , fluid , pedal , prob

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
OBD II Codes Smaky Alfa 145 & 146 62 14-08-19 13:36
Big Brakes thread! Pros and Cons Peter K Tuning & Upgrades 21 10-10-07 20:23
Brake pads Dom Nicosia Alfa 155 10 10-09-02 05:32

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome