Oil warning light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 8 Old 30-05-09 Thread Starter
Status: -
AO Member
 
Join Date: Oct 2004
Posts: 233

Member car:

v6 Spider

Oil warning light

Dear all
I've previously posted about this in the Gtv/Spider forum, but wanted to update and widen the number of potential readers.
I've got a 2001 v6 spider with 90k miles.
Problem is that the oil light flashes on for a second sometimes when starting the engine from hot. Literally just for a second.
Took it to AHM in Hartley Wintney, who really knows his stuff and he checked the oil pressure and said it was fine-something like 20 psi at idle and increasing as it should at higher revs. He changed the pressure switch to try and fix the light, but it still comes on sometimes just as the engine is settling down to idle. Never comes on after that and no funny noises.
Should I worry?
Thank you
xavster is offline  
Sponsored Links
Advertisement
 
Status: One foot in, one foot out!
AO Platinum Member
 
zulu ferret's Avatar
 
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,278
I'm no alfa expert but, erratic sticking pressure relief valve in the oil pump?
zulu ferret is offline  
(Post Link) post #3 of 8 Old 30-05-09 Thread Starter
Status: -
AO Member
 
Join Date: Oct 2004
Posts: 233

Member car:

v6 Spider

What does that mean? Big problem?
xavster is offline  
Status: -
AO Member
 
spider82's Avatar
 
Join Date: Feb 2009
Location: Australia
County: New South Wales
Posts: 221

Member car:

Spider 2.0 JTS

xavster, this is completely normal. Check your manual, it'll say all the warning lights will come on every time you turn on the engine.
hope this helps
spider82 is offline  
(Post Link) post #5 of 8 Old 21-06-09 Thread Starter
Status: -
AO Member
 
Join Date: Oct 2004
Posts: 233

Member car:

v6 Spider

Hi
This is different to the normal start up check. If I start the car from hot, the light goes off then flickers back on for a second.
Thanks
xavster is offline  
Status: -
AO Platinum Member
 
Ralf S.'s Avatar
 
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 13,131
What's the oil level like?

It seems to me you're getting a "surge" as the pump gets going, resulting in a dip in pressure at the sender (not necessarily bad).

Do you have 10W40 in there, or something else? If t only does it when hot, it suggests the oil is maybe too thin?

Ralf S.
Ralf S. is offline  
(Post Link) post #7 of 8 Old 23-06-09 Thread Starter
Status: -
AO Member
 
Join Date: Oct 2004
Posts: 233

Member car:

v6 Spider

Level is fine - it doesn't really use any.

If anything, there might be too much oil...

It's done about 3000 miles since it started - I guess if anything really bad was going to happen, it would have by now....

Thanks for help so far!
xavster is offline  
Status: -
AO Member
 
spider82's Avatar
 
Join Date: Feb 2009
Location: Australia
County: New South Wales
Posts: 221

Member car:

Spider 2.0 JTS

good, i'm glad to hear things went alright
spider82 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
light , oil , warning

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
16 important OIL questions and answers oilman Alfa 147, 156 & GT 339 03-06-18 10:39
156 GTA Oil Pressure Warning Light omni Alfa GTA 4 20-07-09 19:10
Gear Oil Questions and Answers oilman Alfa 147, 156 & GT 0 19-01-08 12:07
Bulb warning light Old Engineer Alfa 147, 156 & GT 6 10-10-06 13:23
166 oil light weirdness alfa_mad Alfa 164 & 166 1 18-01-06 19:31

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome