2.0 L ts water pump - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 09-10-17 Thread Starter
Status: -
AO Member
 
alannmss's Avatar
 
Join Date: Dec 2007
Location: hertfordshire
Posts: 177
2.0 L ts water pump

Hi, I have an over heating problem on my 2.0 L GTV I have changed the thermostat but still overheating so now i suspect the water pump may have failed. I was told by the previous owner that the cam belt was changed about 10k miles ago, so I would of thought the pump would of been changed too but cant be sure. Would anyone know if it is possible to remove and inspect/change the pump without removing the cam belt ? Thanks
alannmss is offline  
Sponsored Links
Advertisement
 
Status: SOLD my 156!
AO Gold Member
 
gazza82's Avatar
 
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 9,061
Simple answer ... no. water pump is run off the cam belt.
gazza82 is offline  
(Post Link) post #3 of 3 Old 09-10-17 Thread Starter
Status: -
AO Member
 
alannmss's Avatar
 
Join Date: Dec 2007
Location: hertfordshire
Posts: 177
Quote:
Originally Posted by gazza82 View Post
Simple answer ... no. water pump is run off the cam belt.
Thanks for the quick reply , yeah I realize its driven by the belt just thought it might be possible if the tension was released as it looks like the back of the belt runs over it .
alannmss is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
pump , water

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome