2.4 jtd overheating,timing belt, cutting out! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 1 Old 10-02-08 Thread Starter
Status: -
Newbie
 
Join Date: May 2007
Location: United Kingdom
County: South Lanarkshire
Posts: 6
2.4 jtd overheating,timing belt, cutting out!

hi there thanks partly to this forum i;ve fixed several probs on my car.

i'm guilty of reading this website, getting answers and not following up wth results so i'm teying to make up for it!

1/ last month my 2.4 jtd sportwagon (2000) would strangely cut out after running for a while, increasing in frequency till after 20mins or so it'd just cut out all the time. 5-10 mins lather it'd start no probs *when it cut out the injector light would come on, just as it does when you are starting, but would not go off* RAC could not find a fault when plugging in their computer!

1/A result: TDM sensor, also known as RPM sencor locataed at bottom rear of engine (not visible) my local mechanic fixed it but said he had a hell of a job cos the old one was welded in! still it cost just 70

i've had more repairs done so check my threads!
cheers paul
pfarre10 is offline  
Sponsored Links
Advertisement
 
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
belt , cutting , jtd , overheating , timing

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome