engine managment light on - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 19 Old 09-02-08 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2008
Location: cumbria
Posts: 15
engine managment light on

hope someone can help !!! press the go pedal gently everything is fine,press it hard engine starts to stutter and engine managment light comes on,ease off light goes out everything fine again.
rooferjack is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
vivian166ti's Avatar
 
Join Date: Feb 2007
Location: United Kingdom
County: Warwickshire
Posts: 788

Member car:

SAAB 9-5 2.3t

Re: engine managment light on

YES MAF.try unplugging it,if running improves and engine management
light stays on thats' it.
You can sometimes be lucky and run the car o.k with the maf disconnected till you get a new one.
vivian166ti is offline  
mikebrown
Status: - Update
Guest
 
Posts: n/a
Re: engine managment light on

or give it a clean...

Remove the MAF - undo the metal clips with a pair of small pliers or lever off with small screwdriver, undo the cable tie which keeps the connector cable tidy to the air duct.and then the connector remove the MAF.

There are 2 TX secrurits screws that clamps the sensor to the MAF body...these can be undone with pliers as they are not to tight.

Pull the sensor head out and stick the MAF body a bowl of luke warm water and slosh about...use a sponge to clean the inside of the MAF body but do not touch the Mesh. then put back in the bowl and leave for about 20 Mins...

To clean the sensor head you need anti-static cleaner from Maplin or any radio hobby store..

Spray liberally all over the head......

You will see a channel in the sensor head, and will notice a wire running inside....you can clean this with a cotton swab with cleaner applied.....don't go to mad just apply gentle pressure.

At the side of the sensor is a metal plate within another channel...you can clean this using the cleaner and some tissue, wedge it in the grove and slide in and out....you can use a small screwdriver to exert more pressure to clean the plate and the edges.

The sensor heads..electonics is sealed so don’t worry too much...but still be careful.

When this is done....rinse the sensor head under luke warm running water from the tap and just cover the top part of the head where you have cleaned...

when done remove the MAF body that was soaking, test the mesh for cleanness with a cotton swab, if still dirty use the anti-static cleaner to clean more..and re wash in luke warm water.

Lay both the sensor and the MAF body...on a tea towel on a radiator to dry ...

Re-Fit the MAF all back together and put back on the car.

mike...
 
Status: i'm back!
AO Gold Member
 
niallmoran's Avatar
 
Join Date: Oct 2003
Location: Dundee
Posts: 6,298

Member car:

'02 156 1.8 TS

Re: engine managment light on

sure it's okay to rinse the sensor head in water??
niallmoran is offline  
(Post Link) post #5 of 19 Old 12-02-08 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2008
Location: cumbria
Posts: 15
Re: engine managment light on

tried disconnecting maf still doing the same plus light on all the time.
rooferjack is offline  
Status: "My other car'sa 166 TWO twice"
AO Gold Member
 
Pomeo's Avatar
 
Join Date: Nov 2006
Location: United Kingdom
County: South Lanarkshire
Posts: 10,869
Re: engine managment light on

Quote:
Originally Posted by mikebrown View Post
or give it a clean...

Remove the MAF - undo the metal clips with a pair of small pliers or lever off with small screwdriver, undo the cable tie which keeps the connector cable tidy to the air duct.and then the connector remove the MAF.

There are 2 TX secrurits screws that clamps the sensor to the MAF body...these can be undone with pliers as they are not to tight.

Pull the sensor head out and stick the MAF body a bowl of luke warm water and slosh about...use a sponge to clean the inside of the MAF body but do not touch the Mesh. then put back in the bowl and leave for about 20 Mins...

To clean the sensor head you need anti-static cleaner from Maplin or any radio hobby store..

Spray liberally all over the head......

You will see a channel in the sensor head, and will notice a wire running inside....you can clean this with a cotton swab with cleaner applied.....don't go to mad just apply gentle pressure.

At the side of the sensor is a metal plate within another channel...you can clean this using the cleaner and some tissue, wedge it in the grove and slide in and out....you can use a small screwdriver to exert more pressure to clean the plate and the edges.

The sensor heads..electonics is sealed so donít worry too much...but still be careful.

When this is done....rinse the sensor head under luke warm running water from the tap and just cover the top part of the head where you have cleaned...

when done remove the MAF body that was soaking, test the mesh for cleanness with a cotton swab, if still dirty use the anti-static cleaner to clean more..and re wash in luke warm water.

Lay both the sensor and the MAF body...on a tea towel on a radiator to dry ...

Re-Fit the MAF all back together and put back on the car.

mike...
That was in the good old days Mike,
Now you get a new one form AEP or similar for £36.50 and fit and fiorget.A lot simpler and what a difference2.


What year is she Roofer?



Pomeo
Pomeo is offline  
Status: "My other car'sa 166 TWO twice"
AO Gold Member
 
Pomeo's Avatar
 
Join Date: Nov 2006
Location: United Kingdom
County: South Lanarkshire
Posts: 10,869
Re: engine managment light on

Quote:
Originally Posted by rooferjack View Post
hope someone can help !!! press the go pedal gently everything is fine,press it hard engine starts to stutter and engine managment light comes on,ease off light goes out everything fine again.
My daughters bravo did a similar thing...It is a 2001 Formula and is EOBD....A diagnositc showed a misfire No4 cylinder .It was the spark plug lead.

Pomeo
Pomeo is offline  
Status: AROC 916 Registrar
AO Gold Member
 
Mitch916's Avatar
 
Join Date: Nov 2002
Location: United Kingdom
County: Kent
Posts: 8,916
Re: engine managment light on

Yeah it might be worth taking it in to have the fault code read.
Mitch916 is offline  
(Post Link) post #9 of 19 Old 12-02-08 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2008
Location: cumbria
Posts: 15
Re: engine managment light on

its 2001 had it in and no faults found.
rooferjack is offline  
Status: AROC 916 Registrar
AO Gold Member
 
Mitch916's Avatar
 
Join Date: Nov 2002
Location: United Kingdom
County: Kent
Posts: 8,916
Re: engine managment light on

?? Managment light on and no faults up ?? Who did the check??
Mitch916 is offline  
Status: i'm back!
AO Gold Member
 
niallmoran's Avatar
 
Join Date: Oct 2003
Location: Dundee
Posts: 6,298

Member car:

'02 156 1.8 TS

Re: engine managment light on

i was wondering that as well as the engine light (either type) is only lit when the ECU logs a fault...
niallmoran is offline  
Status: Back to Alfa
AO Silver Member
 
Dougie166's Avatar
 
Join Date: Aug 2006
Location: United Kingdom
County: Clackmannanshire
Posts: 4,150

Member car:

Giulietta QV

Re: engine managment light on

My Super had management light on when I first bought it - intermittent.

Diagnostic check showed nothing, in fact the check could not be completed as system threw a wobbly.

Fault found the old way (by sight) - Bad earth that was arcing on occassion. This was obviously playing havoc with the diagnostic equipment!
Dougie166 is offline  
(Post Link) post #13 of 19 Old 12-02-08 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2008
Location: cumbria
Posts: 15
Re: engine managment light on

my next door neighbour.light only comes on when you press go pedal to floor,resets itself when you lift off.andeverything runs smoothly again.
rooferjack is offline  
Status: i'm back!
AO Gold Member
 
niallmoran's Avatar
 
Join Date: Oct 2003
Location: Dundee
Posts: 6,298

Member car:

'02 156 1.8 TS

Re: engine managment light on

i always thought that even if the light goes off the fault code is logged in the ECU?
niallmoran is offline  
(Post Link) post #15 of 19 Old 12-02-08 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2008
Location: cumbria
Posts: 15
Re: engine managment light on

i dont know maybe its something simple like dougie166 had.crossed fingers.
rooferjack is offline  
(Post Link) post #16 of 19 Old 12-02-08 Thread Starter
Status: -
AO Member
 
Join Date: Feb 2008
Location: cumbria
Posts: 15
Re: engine managment light on

he did mention the lamba sensors could be at fault but as before nothing showed up.
rooferjack is offline  
Status: "My other car'sa 166 TWO twice"
AO Gold Member
 
Pomeo's Avatar
 
Join Date: Nov 2006
Location: United Kingdom
County: South Lanarkshire
Posts: 10,869
Re: engine managment light on

Quote:
Originally Posted by rooferjack View Post
he did mention the lamba sensors could be at fault but as before nothing showed up.
Here we go roofer..bear with me please.

I bought LAcey coz she was a Y regd 2001...had the engine symbol....Silly me thought EOBD....Pomeo fuel injector symbol...preEOBD.....Lacey was built in 2000....so she is a CF2 engine ...When Pomeo not working great I thought I'll swap the maf and see if any change...Checked maf list 2001..is CF3 and a different MAf from CF2 . However when I checked and found as above swapped laceys maf sensor into pomeo (Miles better than pomeos original ) and got new one for Lacey.Then got bargain new one for Pomeo.

SO LACEY IS IN NO MANS LAND .CAUGHT UP IN THE CHANGE OVER.

So check date of manufacture if possible but an easy way is ...Oh dear hear wee go again NIALL CF2 v CF3 If you have 1 lamba sensor only in the cat you are CF2 ...If you have I think its 4 lambda sensors I think down pipes and somewhere else you will be CF3 and I think a new reader will get the codes.

I was sure of this until yesterday...Niall knows more about the cf3 than me...so if you know which one you are its a starter.

Pomeo

"Don't follow me,Follow the Highway Code "
Pomeo is offline  
Status: Back to Alfa
AO Silver Member
 
Dougie166's Avatar
 
Join Date: Aug 2006
Location: United Kingdom
County: Clackmannanshire
Posts: 4,150

Member car:

Giulietta QV

Re: engine managment light on

Easiest way to check manufacture date and engine type is via Eper - Just put in your chassis number.

I was surprised to note that my CF3 Super was built 2 years before it was actually registered! My FL was only built 1 month before it was registered!
Dougie166 is offline  
Status: I thought I've something more to say
AO Silver Member
 
klapanciusz's Avatar
 
Join Date: Nov 2006
Location: Ireland
County: Wicklow
Posts: 2,620
Re: engine managment light on

I have the engine management light coming up ~ once a month, then after 3-10 restarts it goes off. I didn't find any change in fuel consumption or the way the car drives.
klapanciusz is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engine , light , managment

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome