Alfa engine sillyspeed problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 16 Old 05-02-08 Thread Starter
Status: -
 
Join Date: Jan 2008
Posts: 13
Alfa engine sillyspeed problems

Hi,
I'm back,I posted earlier a weeks back that my aLFA 2002 147 car would not start as it is stuck in Reverse.
After having it diagnosed from an Alfa Service dept they diagnosed that the Sillyspeed actuator needed replacing.
I took my car to an independant Alfa specialist he ordered in a Re-conditioned actuator and had it fitted and installed only to find out that this was not the cause luckily he did not charged me for the part,the part was tested beforehand and proved not to be a faulty part,now my mechanic who has had my car for over 2 weeks is stumped as to what is causing the problem,does anyone have any ideas what is the cause,the battery was tested and tested ok,now it seems the actuator is fine after using a re-conditioned part.
Please help and solutions anyone???????????????????
gezza is offline  
Sponsored Links
Advertisement
 
Status: Gold Member
AO Gold Member
 
rarebear's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,032

Member car:

911, 156, Merc C

Re: Alfa engine sillyspeed problems

sounds like the broken part inside the box , this means a new casing and transferring the content of the stuck box. But I may be wrong..

David C may be helpful....
rarebear is offline  
Status: One foot in, one foot out!
AO Platinum Member
 
zulu ferret's Avatar
 
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,278
Re: Alfa engine sillyspeed problems

Too complicated for the average motorist to come to terms with, those selespeeds, myself included, naturally.: Have a look at Ben'B's backposts, if you can find them. Now there was a DIY seleman' extraordinaire, if ever there was one.: Good Luck.:
zulu ferret is offline  
Status: Gold Member
AO Gold Member
 
rarebear's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,032

Member car:

911, 156, Merc C

Re: Alfa engine sillyspeed problems

From what I hear from my brother most problems with Selespeed are mechanical but are wrongly pointed at the selespeed system.
Once the SS software is up to date and pump and actuator are OK (and enough oil in the SS oil tank) it lasts forever. Gearboxes and clutches not , unfortunately..
rarebear is offline  
Status: One foot in, one foot out!
AO Platinum Member
 
zulu ferret's Avatar
 
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,278
Re: Alfa engine sillyspeed problems

Rarebear, basic transmission problems in the gearbox itself? Your brother has a valid on track view I reckon.:
zulu ferret is offline  
Status: -
AO Member
 
Join Date: Jan 2008
Location: United Kingdom
County: Northamptonshire
Posts: 224
Re: Alfa engine sillyspeed problems

Sounds like either the clutch or gearbox issue. You should get them both checked out at the same time as when my clutch went it stuck in neutral and had the same issue where the Selespeed was being blamed but after a few attempts found the problem.
According to my mechinic to replace the clutch you need to take the gearbox off to get to it anyways so you may aswell get them both checked to save yourself a load of labour.
ChrisSound is offline  
Status: Gold Member
AO Gold Member
 
rarebear's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,032

Member car:

911, 156, Merc C

Re: Alfa engine sillyspeed problems

Quote:
Originally Posted by zulu ferret View Post
Rarebear, basic transmission problems in the gearbox itself? Your brother has a valid on track view I reckon.:
He is chief mechanic in an Alfa dealership, 55 years old and since his 18th year in the car business... good track record I reckon ?!
rarebear is offline  
Status: One foot in, one foot out!
AO Platinum Member
 
zulu ferret's Avatar
 
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,278
Re: Alfa engine sillyspeed problems

Master of his trade, Rarebear, worth listening to, as indeed you yourself are, mate.:
zulu ferret is offline  
Status: Gold Member
AO Gold Member
 
rarebear's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,032

Member car:

911, 156, Merc C

Re: Alfa engine sillyspeed problems

Quote:
Originally Posted by zulu ferret View Post
Master of his trade, Rarebear, worth listening to, as indeed you yourself are, mate.:
you're not bad either !!!

p.s. life is not simple with our Italian Mistress
rarebear is offline  
Status: One foot in, one foot out!
AO Platinum Member
 
zulu ferret's Avatar
 
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,278
Re: Alfa engine sillyspeed problems

The Selespeed is fun to drive, but it's really useful to get good hints and tips from folk such as yourself, David C, and of course, Ben B, before he left.:
zulu ferret is offline  
Status: Gold Member
AO Gold Member
 
rarebear's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,032

Member car:

911, 156, Merc C

Re: Alfa engine sillyspeed problems

Bears are sometimes a bit silly (sele ?) did a (low) bid on Fleebay and see what I got, I was always opposed of these things, but they look not bad ! what do you think ? (be gentle)

p.s. uploaded a piccie but it fell in a black hole apparently ?

Last edited by rarebear; 05-02-08 at 11:32. Reason: picture gone
rarebear is offline  
Status: Gold Member
AO Gold Member
 
rarebear's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,032

Member car:

911, 156, Merc C

Re: Alfa engine sillyspeed problems

piccie

Last edited by rarebear; 18-10-08 at 15:07.
rarebear is offline  
Status: Powered by coal and steam
AO Gold Member
 
EVEL's Avatar
 
Join Date: Jan 2007
Location: England
County: West Midlands
Posts: 9,808

Member car:

alph a ramayo

Re: Alfa engine sillyspeed problems

Quote:
Originally Posted by rarebear View Post
piccie
Very nice rarebear , have you got any pics of the whole car with them on,
EVEL is offline  
Status: -
AO Platinum Member
 
David C's Avatar
 
Join Date: Aug 2003
Location: London, England
Posts: 29,952
Re: Alfa engine sillyspeed problems

Quote:
Originally Posted by gezza View Post
After having it diagnosed from an Alfa Service dept they diagnosed that the Sillyspeed actuator needed replacing.
Sadly that is the response from many main dealer service departments when you take a Selespeed in, no matter what is actually causing the problem.

I can't think what your issue may be at the moment though.
David C is offline  
Status: Gold Member
AO Gold Member
 
rarebear's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,032

Member car:

911, 156, Merc C

Re: Alfa engine sillyspeed problems

I know of cases that they replaced all sele components (cost a fortune) only to find out that the clutch was broken !!!!
so much for expertise !!!
rarebear is offline  
Status: Gold Member
AO Gold Member
 
rarebear's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,032

Member car:

911, 156, Merc C

Re: Alfa engine sillyspeed problems

Evel will do ! never planned to buy these things but I did a silly low bid on Fleebay and got these things... then I thought what the hell.. lets try them on, I can always take them off. The funny thing is that I had some guys asking me where I got these Brembo calipers ??!!! so they look real but I must admit that its not my way to have fake stuff on my car..
rarebear is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
alfa , engine , problems , sillyspeed

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome