Oil Pump Failure in 2.0 Engines ?? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 2 Old 26-01-08 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2007
Location: Tyne & Wear
County: Tyne and Wear
Posts: 101
Crazed Oil Pump Failure in 2.0 Engines ??

Having read the Dec. AROC mag I noticed with interest details of a 156 2.0 JTS owner whose car had suffered oil pump failure at 20,000 mile, munching its engine !!

Whilst reasearching details about Alfa ownership before buying my own 156 over 4 years ago, Honest John's excellent car by car web guide did highlight "the worrying number of 2.0 engine failures due to oil starvation when the engines were full of oil points a finger to oil pump failure"

Is anyone aware of this regularly occurring with 2.0 engines as a problem/weakness ?? If it appears to be only a 2.0 related problem, do the technical/mechanical wizards on the forum think this is due to the odd duff oil pump being fitted by Alfa ?? or could it be caused by owners lack of attention eg, infrequent oil/filter changes, incorrect grade of oil ??

Any views/comments on what can cause an oil pump to fail ??
jaf156 is online now  
Sponsored Links
Advertisement
 
Status: zzzzzzzz
AO Platinum Member
 
symon's Avatar
 
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 37,013
Re: Oil Pump Failure in 2.0 Engines ??

I haven't ever heard of a TS or JTS engine with a faulty oil pump causing failure. I suspect many of the people on the honest John website have actually run the cars low on oil, but don't want to admit to it for warranty reasons. Often a car can be run low on oil and problems will not surface for a few thousand miles later, and when they do surface it just so happens the engine at that time has plenty of oil in it..
Oil pump failure is an exteremely rare occurance, although if you were to rebuild a well used engine they are often changed as a matter of course.

Simon.

Giulietta 2.0JTDm (170), BMW 335i Cabrio
symon is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
engines , failure , oil , pump

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome