GTV engine coolant...gone!? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 24-01-08 Thread Starter
Status: -
AO Member
 
Mantress's Avatar
 
Join Date: Oct 2007
Location: Derbyshire
Posts: 53
Hmmm GTV engine coolant...gone!?

Hello,

My coolant keeps disappearing. I've been topping up the coolant a few times a month since I got my GTV (3L V6). There's no sign of any leak.

Is this normal?

I had to top up this morning as the level was below minimum. I'm baffled.
Mantress is offline  
Sponsored Links
Advertisement
 
Status: pretty good actually...!
AO Member
 
Cibo's Avatar
 
Join Date: May 2007
Location: Ireland
Posts: 698

Member car:

916 Spider

Re: GTV engine coolant...gone!?

Check the radiator for damage, if it is leaking you probably won't see any obvious leak as it would evaporate.

I noticed my coolant level dropping since Christmas and dropped into my independent specialist. One quick look and he diagnosed a new radiator required. Pretty obvious when he showed me where to look....
Cibo is offline  
Status: -
AO Member
 
Rod Duggan's Avatar
 
Join Date: Jan 2008
Location: Surrey
Posts: 312

Member car:

Spider 2000

Re: GTV engine coolant...gone!?

Check the pressure cap - if it isn't sealing and holding then there'll be evaporation when running.
Or it could be head gasket leaking, but check the radiator/hoses cap first.
Rod Duggan is offline  
Chris155
Status: - Update
Guest
 
Posts: n/a
Re: GTV engine coolant...gone!?

As said before, radiator and expansion tank carps would be my prime suspects.

Have you checked the dipstick / expansion tank for signs of "mayonaise"?

Does the level drop to a specfic level and then stop or does it continue to dissapear untill you refill it? The reason I ask is my old 2.5 156 used to drop to the min mark on the expansion tank and stop there. I could top it up but after to days it would be back on min and stable at that level.
 
Status: Thinking of what Alfa to buy next!
AO Silver Member
 
GTV Bertone's Avatar
 
Join Date: Mar 2005
Location: United Kingdom
County: Greater London
Posts: 1,096

Member car:

Alfa GT 1.9 JTDm

Re: GTV engine coolant...gone!?

A specialist must be able to do a pressure test on the system, mine was leaking into the front passenger foot well, it was the small coolant pipe for the heating under the dash board.
GTV Bertone is offline  
(Post Link) post #6 of 6 Old 30-01-08 Thread Starter
Status: -
AO Member
 
Mantress's Avatar
 
Join Date: Oct 2007
Location: Derbyshire
Posts: 53
Re: GTV engine coolant...gone!?

Thanks guys. The pressure seems to be fine. I get the 'hiss' of air when taking the cap off. It looks to be the radiator, looked a bit black when I checked underneath for leaks, I also spotted a coolant leak. Looks like it’s back to the garage…again.

Does anyone know what the cost of this could be? I should think it’s fairly expensive.
Mantress is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
coolantgone , engine , gtv

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome