147 Engine Noise and Rough idle - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 23-01-08 Thread Starter
Status: -
Newbie
 
Join Date: Mar 2005
Location: Melbourne, Australia
Posts: 7
147 Engine Noise and Rough idle

Hi all,

Over the last few (actually many) months my 147 started to idle rough when stopped at lights. Then it developed a slight surge when accelerating. the surge got worse and worse to the point where low down, not a lot was happening. Only when I would get to 4,00rpm did it clear.

At the same time I began hearing loud noises from the engine bay. So loud in fact that at times people turned to see what the noise was.
So i jumped on here and started my searches. The noise i was convinced was coming from the heat shield judging from what i found on this forum site. Renowned for cracking i checked and found a crack on either side of it about half way down. I seperated the two bits to see if the noise would stop. To my dismay it did not. The noise continued and it was getting annoying. It would occur at around 2,500-3,000 rpm, nothing before and nothing after. I couldnt help but connect the noise and surging to a faulty variator.

Off it went to the dealer. I was dreading the worst.

To my utter joy the noise turned out to actually be the heat shield but it was rattling against the mount bolts of the exhaust maifoold. A few washers and noise was gone.

The surge turned out to be a dirty variator phase plunger sensor. Basically this senses the cam profile and adjusts it accordingly. Mine was stuck in an advanced stage hence the rough idle. It was merely a matter of removing, cleaning and polishing and back in.

Now she runs like a dream. Smooth as the day i got her.

Just thought i would share this in case anybody experiences the same issues.

Now i need to careful and not get a speeding ticket...

See ya...
aus147 is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Aug 2007
Posts: 42

Member car:

147 Lusso

Re: 147 Engine Noise and Rough idle

Very useful to report this - thanks

I normally associate nasty noises and rough running with those diesel things
Tim16V is offline  
Status: Waiting for Stelvio QV
AO Platinum Member
 
OperationAlfa's Avatar
 
Join Date: May 2007
Location: United Kingdom
County: Essex
Posts: 23,452
Re: 147 Engine Noise and Rough idle

Variators are common to go. Make the car sound nasty like a diesel. They spring needs to be replaced inside them, or just replace the unit. £90.

However, the cambelt has to come off to change the variator, so I hope they did not put the original cambelt back on... The variator will cause a loss in MPG.

The heat shield is also common to make a noise. If it isn't the shield, then its the cat bracket.

OA
OperationAlfa is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
147 , engine , idle , noise , rough

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome