Tappet pinging noise???? Alfa 156, 2.0L, 16v, Selespeed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 3 Old 26-10-16 Thread Starter
Status: -
AO Member
 
alfanatik's Avatar
 
Join Date: Sep 2016
County: -
Posts: 140
Tappet pinging noise???? Alfa 156, 2.0L, 16v, Selespeed

Hi guys,

After repairing my starter yesterday, I took my car for a drive. Noticed a tappet pinging noise while driving in traffic especially when engine is hot. The heat guage was normal (90).*
Also noticed it before at that temp.

Its Ok on low revs but pinging starts as soon as I floor it a bit.*

When engine has cooled down, its fine no pinging especially in the mornings, only when engine is hot and when weather conditions are high which sometimes reaches up to an abient of 30C to 40C in my part of the world.

Any comments will be highly appreciated!!!!

Could it be the oil i'm using pehaps (Motul. 8100 - 10W60)
alfanatik is offline  
Sponsored Links
Advertisement
 
Status: trapped in an old git's body
AO Member
 
AL159's Avatar
 
Join Date: Jul 2008
Location: liverpool
County: Merseyside
Posts: 491
Garage
get a stethoscope out on it. Possibly also could be an exhaust manifold gasket leak when hot??
AL159 is offline  
(Post Link) post #3 of 3 Old 27-10-16 Thread Starter
Status: -
AO Member
 
alfanatik's Avatar
 
Join Date: Sep 2016
County: -
Posts: 140
Quote:
Originally Posted by AL159 View Post
get a stethoscope out on it. Possibly also could be an exhaust manifold gasket leak when hot??
Thanks mate i'll have a look at that. Also gonna check the themostat, and radiator fan, 'cos it gets too hot when driving in "bumper to bumper" traffic, especially in hot weather conditions
alfanatik is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
156 , 16v , 20l , alfa , noise , pinging , selespeed , tappet

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome