Injector warning light plus engine fan on cold weather - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 13 Old 29-12-07 Thread Starter
Status: Headed back to New England
AO Silver Member
 
pierre_samanni's Avatar
 
Join Date: Feb 2005
Location: United States
County: Armed Forces Europe
Posts: 1,028
Hmmm Injector warning light plus engine fan on cold weather

Ciao fellow 155isti,

Lately the temperatures have been a bit low, despite Napoli being by the sea and all and this is what's happening these days to my 155 by temperatures below 5 Celsius.

Usually after some freeway driving at about 60 mph in 5th gear, the injection warning light comes on and I hear a relay activate. The engine temp then goes from about 70 to the min. Then by the time I arrive at work and park the car, I realize the engine fan has been on because I can hear it blowing.

Does that sound familiar to anyone?
pierre_samanni is offline  
Sponsored Links
Advertisement
 
Status: playing kill by numbers
AO Gold Member
 
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 8,786
Re: Injector warning light plus engine fan on cold weather

sound like the sensor for the coolant temperature (the one for the ecu, not the one for the dash) has a bad connection.

When the ecu doesn't know the engine temp it will switch the fans on, and run rich. How's the mileage?
Cuore_Sportivo_155 is offline  
(Post Link) post #3 of 13 Old 30-12-07 Thread Starter
Status: Headed back to New England
AO Silver Member
 
pierre_samanni's Avatar
 
Join Date: Feb 2005
Location: United States
County: Armed Forces Europe
Posts: 1,028
Re: Injector warning light plus engine fan on cold weather

Thanks for the prompt answer! Sounds like a good possibility indeed.

The mileage hasn't varied sensibly, but I also need to get the speedometer fixed (it's playing the yo-yo these days) and I have another connection that needs fixing. So it'll see the car electrician on Thursday, hopefully that will fix it. :-)
pierre_samanni is offline  
Status: playing kill by numbers
AO Gold Member
 
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 8,786
Re: Injector warning light plus engine fan on cold weather

do you have a '97 car? take the dash out, and tighten the brass nuts on the back of the speedo... bye-bye yo-yo
Cuore_Sportivo_155 is offline  
(Post Link) post #5 of 13 Old 30-12-07 Thread Starter
Status: Headed back to New England
AO Silver Member
 
pierre_samanni's Avatar
 
Join Date: Feb 2005
Location: United States
County: Armed Forces Europe
Posts: 1,028
Re: Injector warning light plus engine fan on cold weather

I did that two times already. It did work for a while the first time, then for not very long the second time. For some reason it seems to be happening on bumps, almost always the same on my freeway commute. Sounds like a shady connection issue... Wouldn't be the first.
pierre_samanni is offline  
Status: playing kill by numbers
AO Gold Member
 
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 8,786
Re: Injector warning light plus engine fan on cold weather

check the connector on the box under the battery tray. sqpray liberally with WD40 (inside the connector)
Cuore_Sportivo_155 is offline  
(Post Link) post #7 of 13 Old 03-01-08 Thread Starter
Status: Headed back to New England
AO Silver Member
 
pierre_samanni's Avatar
 
Join Date: Feb 2005
Location: United States
County: Armed Forces Europe
Posts: 1,028
Re: Injector warning light plus engine fan on cold weather

Thanks for the advice! I'll give it a try if the problem shows up again. She's in the shop today, so we'll see how it goes over the next few days.
pierre_samanni is offline  
(Post Link) post #8 of 13 Old 06-01-08 Thread Starter
Status: Headed back to New England
AO Silver Member
 
pierre_samanni's Avatar
 
Join Date: Feb 2005
Location: United States
County: Armed Forces Europe
Posts: 1,028
Re: Injector warning light plus engine fan on cold weather

Arf... another so-so experience at a mechanic - actually an "elettrauto", someone specialized in car electrics.

Turns out the thermostat needed changing, and I would agree with that, since I picked up the car 2 days ago it feels more responsive.

But the guy changed the rpm sensor with no effect on the "boing-boing" speedo-effect, and the injector warning light plus engine fan has come up on two cold starts. He says that would probably mean the lambda probe needs changing. Does that sound right?

I am taking the car back for the the "boing-boing" thing, but I'd rather have some confirmation here that he's not taking me for a ride...
pierre_samanni is offline  
mo4
Status: back in a 156
AO Member
 
Join Date: Mar 2005
Location: Ireland
County: -
Posts: 731
Re: Injector warning light plus engine fan on cold weather

Any problems relating to cold starting definitely not related to lambda probe. The lambda is only used after the engine reaches operating temp (ECU closed loop program)

.... not sure how the rpm sensor could affect the speedo either. AFAIK there's a sender on the gearbox but open to correction on this....
mo4 is offline  
(Post Link) post #10 of 13 Old 06-01-08 Thread Starter
Status: Headed back to New England
AO Silver Member
 
pierre_samanni's Avatar
 
Join Date: Feb 2005
Location: United States
County: Armed Forces Europe
Posts: 1,028
Re: Injector warning light plus engine fan on cold weather

Thanks for the help mo4, indeed I also found another post mentioning your point. So that tomorrow evening, the MAF is coming out to check out if the car runs better without it. And it's also high time for me to change the exhaust pipe as well, that has to be playing a part too...

<<The lambda sensor is out of circuit during cold starts until the car warms up, so that is not your issue.

The MAF (air flow meter) is a more likley culprit.>>
pierre_samanni is offline  
(Post Link) post #11 of 13 Old 13-01-08 Thread Starter
Status: Headed back to New England
AO Silver Member
 
pierre_samanni's Avatar
 
Join Date: Feb 2005
Location: United States
County: Armed Forces Europe
Posts: 1,028
Re: Injector warning light plus engine fan on cold weather

Well since the new thermostat was changed, I got the injector warning light on 2 or 3 times on a cold start, but the car was already more responsive. That said I knew it was time to get a new exhaust (center and rear) and...

Voila! A custom exhaust fitting job later, the engine is much smoothier and so much more responsive even to a slight touch of the accelerator. Joy!
pierre_samanni is offline  
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
 
Joss's Avatar
 
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 19,112
Garage
Re: Injector warning light plus engine fan on cold weather

Is the speedo going completely dead when you are driving and then coming back or just up and down. Mine did both anyway and the fault i found was in the back of the speedo. Take the instrument pod out. remove the white protective cover on the back. Cant remenber how to do it off hand because it was so long ago but its pretty obvious which bolts and things to undo. Once the cover is off spray some WD40 over the very back part of the speedo mechanism the bit that has the three brass bolts on it. Make sure you get all inside as thats the important bit. Careful not to over do it though as the WD can leak onto the dials. I managed that and it now looks a bit of a mess. but it is disappearing slowly!!! Hasn't had any problems since.

Hope that helps.

Joss
Joss is offline  
(Post Link) post #13 of 13 Old 30-01-08 Thread Starter
Status: Headed back to New England
AO Silver Member
 
pierre_samanni's Avatar
 
Join Date: Feb 2005
Location: United States
County: Armed Forces Europe
Posts: 1,028
Re: Injector warning light plus engine fan on cold weather

Thanks for the advice Joss. In the mean time I went to my car electrics guy and apparently, an aging/loose soldering point was the issue. All fixed now! :-)
pierre_samanni is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Engines (TS, JTS, JTD & V6)

Tags
cold , engine , fan , injector , light , warning , weather

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome