Bosch Aquatak 100 plus - Snow foam ? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 09-03-10 Thread Starter
Status: -
AO Member
 
Thebossman's Avatar
 
Join Date: Jul 2009
Location: United Kingdom
County: Hampshire
Posts: 327

Member car:

Alfa Mito

Bosch Aquatak 100 plus - Snow foam ?

I must confess I have always been lazy when it comes to car washing, only occasionally going to an automated garage car wash.

Since buying my Mito I have been very slightly better in as much as going to the local handwash place, but now feel it's about time I stopped being so lazy and did it myself.

I fancy having a go with snowfoam, but I have an Aquatak 100 plus with a detergent bottle attachment. Could I use this for snowfoaming ? If so, any recommendations for the best snowfoam to buy?

Also I have a coupe of light scratches on my bonnet, will AG Super resin polish get this sort of things out?
Thebossman is offline  
Sponsored Links
Advertisement
 
Status: loving a shiny bella called Monica
AO Silver Member
 
bigjim's Avatar
 
Join Date: Oct 2007
Location: United Kingdom
County: Northamptonshire
Posts: 2,406

Member car:

159 2.4 Lusso

Valet PRO pH Neutral Snow Foam 1 Litre - Buy online from i4detailing.co.uk i use this in a superspray so i can't see why you'd not get similar or if not better results with your detergent bottle.
srp comes highly recommended. just make sure you seal it with wax or sealent afterwards.
have fun. you'll be addicted sooner rather than later.
bigjim is offline  
Status: winner of the pro alfa comp :)
AO Silver Member
 
john147's Avatar
 
Join Date: Jun 2006
Location: United Kingdom
County: Gloucestershire
Posts: 1,476
this guys good for detailing stuff and if ya local to him u can pick it up to save on postage Detailed2Perfection, Detailing Supplies, Car Cleaning Products
john147 is offline  
(Post Link) post #4 of 6 Old 14-03-10 Thread Starter
Status: -
AO Member
 
Thebossman's Avatar
 
Join Date: Jul 2009
Location: United Kingdom
County: Hampshire
Posts: 327

Member car:

Alfa Mito

Hmm I bought some ultimate snow foam, yet when I used it in the detergent bottle, there was no foam, just a bubbly liquid solution. I tried various mixes of solution but no luck. Also, with these detergent bottles, isnt the water from the pressure washer supposed to mix with the solution, or should the 0.5l detergent bottle empty within 5 seconds?! I was thinking it would take a while!

Otherwise, anyone had any good results with snow foam from the cheaper pump bottle types?

Gave the Mito my first really good wash today, with various AG products, Aquawax is fantastic, but boy do I get through it!
Thebossman is offline  
Status: loving a shiny bella called Monica
AO Silver Member
 
bigjim's Avatar
 
Join Date: Oct 2007
Location: United Kingdom
County: Northamptonshire
Posts: 2,406

Member car:

159 2.4 Lusso

Superspray Car Wash Cleaning Shampoo Hose End Sprayer FREE UK P&P @ Performance Motorcare Products Ltd
this is what i've got. it doesn't give you thick foam, that only comes with a foam lance and pressure washer but it's not bad.
you only need one spray per panel with the aquawax, a little goes a long way. you puting it on a wet car and then using two microfibre cloths to soak up the water and polish off?
bigjim is offline  
(Post Link) post #6 of 6 Old 15-03-10 Thread Starter
Status: -
AO Member
 
Thebossman's Avatar
 
Join Date: Jul 2009
Location: United Kingdom
County: Hampshire
Posts: 327

Member car:

Alfa Mito

Thanks, was looking at the superspray on another thread, but everywhere seems out of stock at the moment.

With regards the aquawax, yes i'm using it on a wet car with two cloths, but am spraying a lot more than one spray per panel!
Thebossman is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Car Detailing

Tags
100 , aquatak , bosch , foam , snow

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Overboost problem (again) fluffybunny Alfa 147, 156 & GT 13 05-01-10 19:53

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome