Oil Filter Issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 2 Old 05-12-17 Thread Starter
Status: -
Authorised Trader
 
Philip@Alfashop's Avatar
 
Join Date: Dec 2013
Location: United Kingdom
County: Norfolk
Posts: 343
Oil Filter Issues

OIL FILTER PROBLEMS.......MiTo & Giulietta JTD engines. We have experienced problems with GENUINE OIL FILTER 71754237. The seal provided with the filter becomes hard and fails. This causes the car to lose its oil. If your car has had a Genuine oil filter fitted it needs checking ASAP. We will be contacting our workshop customers that have had this item fitted. Our CLEAN (brand) oil filters are not affected.
Attached Images
File Type: jpg FILTER.jpg (127.8 KB, 14 views)
File Type: jpg clean.jpg (107.2 KB, 10 views)
[email protected] is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Jan 2017
Location: Ireland
County: Sligo
Posts: 46
Quote:
Originally Posted by [email protected] View Post
OIL FILTER PROBLEMS.......MiTo & Giulietta JTD engines. We have experienced problems with GENUINE OIL FILTER 71754237. The seal provided with the filter becomes hard and fails. This causes the car to lose its oil. If your car has had a Genuine oil filter fitted it needs checking ASAP. We will be contacting our workshop customers that have had this item fitted. Our CLEAN (brand) oil filters are not affected.
Could this be a "MADE IN CHINA" problem ?
Alfafrolics1 is offline  
Reply

Go Back   Alfa Romeo Forum > Vendors > AO Trade Village > Alfashop

Tags
filter , issues , oil

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome