147 GTA - Ringtool project - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 14Likes
  • 4 Post By CaptainBigleux
  • 3 Post By Andy Bowden
  • 5 Post By CaptainBigleux
  • 2 Post By CaptainBigleux
 
Thread Tools
(Post Link) post #1 of 6 Old 10-07-19 Thread Starter
Status: -
Newbie
 
CaptainBigleux's Avatar
 
Join Date: Jul 2019
Location: Martinique
County: FRANCE
Posts: 5

Member car:

147 GTA

147 GTA - Ringtool project

Hi guys !

I drove many GTA back in the days when it was new. I always told myself I will get one some day... but always bought something else (Lotus Elise, Esprit V8, Z3 coupe, Abarth, Mini GP...).

Finally I bought one !






The car is a late 2003, with 150.00km.
2 owners before myself (mostly one since the car was one year old). The car was serviced (last timing in sept 18), many parts already changed (ECU, control arms...), clean chassis, no rust, but left in storage since 2012, and body in bad conditions.
I got it for pretty good price. The idea was to save budget on the purchase, to have budget for lot of upgrades...

Not talking about engines, which is good enough, but to make handling at level of the engine.
As I had a mini GP1 before, I wanted to recreate the concept of 2 seats clubsport, and even further.

so, I already ordered lot of parts (some here, some on the way). Not exhaustive list :
- pair of Recaro pole position + mounting
- wiechers front and rear strut braces
- 330 brake upgrade + RC6 pads + goodridge lines
- powerflex blackseries full kit
- KW V3
- quaife
- full wizard exhaust (only keeping central cats)
-...






We did a first service oil change Yacco 10w60 + filters 2 weeks ago, before starting tuning:



But after 1000km after purchase, I got engine light. Very rough idle, ok between 2000 and 3000RPM, but ECU cutting just above.
Codes say misfires (what a surprise lol), cams position sensor error.
We expect many causes : timing belt gone wrong (but I did 500km to come back home like that, so I hope not that), sensor, or coil packs or....
We will see soon, anyway my mechanic want to remove engine to do big service, clutch, timing (even if done less than a year ago), and wizard exhaust manifolds.


Also, I bought remanufactured 330 calipers (see picture above). Just need a fresh red paint... but missing something as you can see. The mounting brackets !
Anyone know if you can by that to alfa directly (and which part number) ? Or where to get it ?

Thanks

Last edited by CaptainBigleux; 10-07-19 at 20:15.
CaptainBigleux is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
Join Date: Jun 2003
Location: Gloucestershire, England
Posts: 1,255
Quote:
Originally Posted by CaptainBigleux View Post
Hi guys !

I drove many GTA back in the days when it was new. I always told myself I will get one some day... but always bought something else (Lotus Elise, Esprit V8, Z3 coupe, Abarth, Mini GP...).

Finally I bought one !






The car is a late 2003, with 150.00km.
2 owners before myself (mostly one since the car was one year old). The car was serviced (last timing in sept 18), many parts already changed (ECU, control arms...), clean chassis, no rust, but left in storage since 2012, and body in bad conditions.
I got it for pretty good price. The idea was to save budget on the purchase, to have budget for lot of upgrades...

Not talking about engines, which is good enough, but to make handling at level of the engine.
As I had a mini GP1 before, I wanted to recreate the concept of 2 seats clubsport, and even further.

so, I already ordered lot of parts (some here, some on the way). Not exhaustive list :
- pair of Recaro pole position + mounting
- wiechers front and rear strut braces
- 330 brake upgrade + RC6 pads + goodridge lines
- powerflex blackseries full kit
- KW V3
- quaife
- full wizard exhaust (only keeping central cats)
-...






We did a first service oil change Yacco 10w60 + filters 2 weeks ago, before starting tuning:



But after 1000km after purchase, I got engine light. Very rough idle, ok between 2000 and 3000RPM, but ECU cutting just above.
Codes say misfires (what a surprise lol), cams position sensor error.
We expect many causes : timing belt gone wrong (but I did 500km to come back home like that, so I hope not that), sensor, or coil packs or....
We will see soon, anyway my mechanic want to remove engine to do big service, clutch, timing (even if done less than a year ago), and wizard exhaust manifolds.


Also, I bought remanufactured 330 calipers (see picture above). Just need a fresh red paint... but missing something as you can see. The mounting brackets !
Anyone know if you can by that to alfa directly (and which part number) ? Or where to get it ?

Thanks
After my 156 GTA had been off the road for a while I had some misfire warnings. They were easily traced to a couple of coil packs.

My suspicion is that the coil packs can collect condensation over a period of non-use.

Coil packs can't cause the cam position sensor warning. Perhaps someone did a cam belt change with the 3.0V6 cam locks rather than the GTA ones.

Andy
Andy Bowden is offline  
(Post Link) post #3 of 6 Old 11-09-19 Thread Starter
Status: -
Newbie
 
CaptainBigleux's Avatar
 
Join Date: Jul 2019
Location: Martinique
County: FRANCE
Posts: 5

Member car:

147 GTA

More parts coming in, soon we'll start the job :






and more important, parts from Wizard :




I ended up buying from him a used set of 330mm calipers, as I can't find spare brackets alone.
I will copy them and resell the kit later on.

Just waiting for the rest of the exhaust, and rear eibach ARB.

Last order to place is the big service : clutch, timing kit, plugs, coils, alternator, O2 sensor...
CaptainBigleux is offline  
Status: saving for a return
AO Member
 
noccy's Avatar
 
Join Date: Aug 2010
Location: Ireland
County: Waterford
Posts: 68
Oh this will be good! Great selection of parts already.
noccy is offline  
(Post Link) post #5 of 6 Old 4 Weeks Ago Thread Starter
Status: -
Newbie
 
CaptainBigleux's Avatar
 
Join Date: Jul 2019
Location: Martinique
County: FRANCE
Posts: 5

Member car:

147 GTA

last package :
CaptainBigleux is offline  
(Post Link) post #6 of 6 Old 4 Weeks Ago
Status: -
Newbie
 
Join Date: Jul 2019
Location: Finland
County: -
Posts: 1
Looking good! Those parts will transform the car!

Have you considered selling your original leather GTA interior?

Previous owner of mine had change Recaro Speed driver's seat and I would like to put it back to original....
HarriGTA is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTA

Tags
147 , gta , project , ringtool

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome