Won't start - help!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 2Likes
  • 2 Post By sargentsiri
 
Thread Tools
(Post Link) post #1 of 6 Old 3 Weeks Ago Thread Starter
Status: -
Newbie
 
Join Date: May 2019
Location: Derbyshire
County: - UK
Posts: 7

Member car:

Giulietta

Won't start - help!!

G stopped at the traffic lights on stop start and wouldn't restart. Got towed home & Since this we have taken the starter motor off - which works fine.
We then found an incorrect battery had been fitted by a previous owner so we have changed this for a correct stop start battery & still the G won't start.

Does anyone have any ideas/ suggestions/ experiences with the G that might help us get her restarted please!
sargentsiri is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 6 Old 3 Weeks Ago
Status: -
AO Member
 
Join Date: May 2009
Location: United Kingdom
County: West Yorkshire
Posts: 181
When you say 'it won't start' do you mean it's turning over and won't fire or it's not turning over? I assume the latter otherwise you wouldn't have taken the starter motor out.
If it's not turning over, it could be a broken earth strap although I'm not sure where it is. It has been mentioned on this forum before.
hisnhers is offline  
(Post Link) post #3 of 6 Old 3 Weeks Ago
Status: -
AO Silver Member
 
Join Date: Nov 2012
Location: Wiltshire
County: -
Posts: 2,061
Have you tested for power to starter when turning ignition key?
I assume it does not turn over rather than turning but not firing?
johnnyroper is offline  
(Post Link) post #4 of 6 Old 3 Weeks Ago
mru
Status: ready for new radio!
AO Member
 
mru's Avatar
 
Join Date: Jan 2017
Location: Not far from here
County: Germany
Posts: 797
Garage
I am having some work done on my car (limp mode plus got rear ended....)

He discovered that a marten (big rat) chewed the cable to the blow off valve actuator, and did major damage to the earth strap. One more bite and it would have been through.....
BTW you can only see it with the under-tray removed......
mru is offline  
(Post Link) post #5 of 6 Old 3 Weeks Ago Thread Starter
Status: -
Newbie
 
Join Date: May 2019
Location: Derbyshire
County: - UK
Posts: 7

Member car:

Giulietta

Quote:
Originally Posted by hisnhers View Post
When you say 'it won't start' do you mean it's turning over and won't fire or it's not turning over? I assume the latter otherwise you wouldn't have taken the starter motor out.
If it's not turning over, it could be a broken earth strap although I'm not sure where it is. It has been mentioned on this forum before.
We have a winner - after a new battery, starter motor on & off - it turned out to be a broken earth strap to the gearbox! Bugger had broken inside the plastic casing - unbelievable!

Thanks for all the help guys
mru and 147Alfaguy like this.
sargentsiri is offline  
(Post Link) post #6 of 6 Old 3 Weeks Ago
Status: -
AO Member
 
Join Date: Nov 2017
Location: Nantwich
County: -Cheshire
Posts: 114
What a good forum.
Robden is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa Giulietta

Tags
start

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome