MA TCT 170 - Hunting idle when climate control off and a strange whistling sound - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 7 Old 15-02-19 Thread Starter
Status: -
Newbie
 
lobbo's Avatar
 
Join Date: Aug 2018
County: -
Posts: 5
Garage
MA TCT 170 - Hunting idle when climate control off and a strange whistling sound

Hi all, I am quite new to the forums, but I'm hoping to get some advice from other Giulietta owners.
I bought my G TCT QV Line 170 MA in September last year and my partner and I absolutely love the car, but it has recently developed some niggling issues, and one of them making the car annoying to drive.

The first part is a hunting idle which only occurs when the climate control is turned off. When it is on, idle is fixed to its normal idle speed.
I had a service recently at an Alfa Romeo dealer and brought it up. They had a look and said there was an air leak, perhaps where the rubber seal has degraded on the injectors.
They wanted an additional £144 to perform a smoke test to confirm this, and quoted me a worst case scenario fix (all 4 injectors replaced & O2 sensor) of £1300.
I took the car from them and went to my local independent garage who specialise in turbo cars (Subaru mainly) for a second opinion. I told them what the Alfa dealer said and they looked over the car, and the injectors and said they couldn't find any air leaks and all 4 injectors were working perfectly.
I've uploaded a video here to demonstrate this.

Secondly, it has recently started making a whistling sound, almost identical to the sound you get when you blow over a top of a bottle.
This seems to only happen when the car is warmed up and seems to be louder when you push down the throttle but doesn't change pitch with vehicle speed.
It has become infuriating to drive as it will happen every time i drive too and from work. However, i very rarely hear the noise when I am at motorway speeds. It seems loudest cruising at 30-40 mph. I have tried to find the source myself but I can't get it to happen when the car is stationary, although changing to neutral while the car is moving the noise will still be there but be quieter.
Here is a video of this sound, its louder nearer the end.
lobbo is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Mar 2016
County: Greece
Posts: 10
My opinion for the first part is that the idle control valve has an issue... best way to start with this is to plug the car to a decent fault reader.
For the second part it sounds like wind... i would check the arc liners for gaps or play, testing with the mirrors closed, maybe some scotch tape to windshield if rubbers around are left. Can you specify from where it sounds?
ChristopherRiis is offline  
Status: -
AO Member
 
Join Date: Feb 2016
County: -
Posts: 230
1. Don't pay dealers for anything.
2. You need to check if there are any fault codes and read up on Idle Air Control diagnostics. Long and Short Term Fuel Trim can be used to detect a vacuum leak (and if you suspect one you can probably DIY leak find it). The last thing you want to do in this case is so throw parts at the problem (which is what the dealership is proposing) as it'll get expensive quick.
jomper is offline  
(Post Link) post #4 of 7 Old 16-02-19 Thread Starter
Status: -
Newbie
 
lobbo's Avatar
 
Join Date: Aug 2018
County: -
Posts: 5
Garage
Ah fault codes I should have mentioned when the car was serviced it was checked and they said said there was a stored fault code of P0171 (running lean) but I was told that as I haven't seen an engine management light and it was stored it could have been something from the past?
He reset the ECU to see if it comes back but when it went to the other garage (sabura specialist) they said there were no fault codes on the car.

Again this was an Alfa Dealer and after being there twice I'm not sure how much I trust them.

I will try the mirror trick for the whistling but it only happens after the car is warm and doesn't get louder with speed, just throttle position
lobbo is offline  
Status: -
AO Silver Member
 
Join Date: Nov 2012
Location: Wiltshire
County: -
Posts: 1,901
If it’s with engine speed rather than vehicle speed that rules out wind noise. I would be looking at hoses,pipes and gaskets for potential air leaks. When it is warm at idle sparky some brake cleaner around manifold joints and pipe work to see if engine note changes.
johnnyroper is offline  
(Post Link) post #6 of 7 Old 1 Week Ago
Status: -
Newbie
 
Join Date: Dec 2018
County: -
Posts: 2
Exactly the same issue with you regarding the idle when AC is off.Did you find a solution;
kbouz is offline  
(Post Link) post #7 of 7 Old 6 Days Ago Thread Starter
Status: -
Newbie
 
lobbo's Avatar
 
Join Date: Aug 2018
County: -
Posts: 5
Garage
Quote:
Originally Posted by kbouz View Post
Exactly the same issue with you regarding the idle when AC is off.Did you find a solution;
Hi no solution to the air conditioning idle issue yet.

I had to go to my local dealer recently to get the DAB radio repaired under warranty, but while it was their and since I had a courtesy car arranged, I left it with them for some diagnostic on the idle speed. They said that it could be caused by an air leak but they performed a smoke test (pressurise the engine with a smoke machine to see where it leaks) and couldn't find what it is. They basically just told me "oh well, can't find it, you go home now".

I did speak to another mechanic on Saturday at my local regular garage regarding this and he suggested that it could be a problem with the ECU as he's seen something similar on a different car which was fixed after replacing the ECU. He said that the dealers behaviour could also suggest that as it's something they wouldn't want to have to pay to replace in warranty as its expensive.

I will be returning to the dealer and asking them what they can do next though.




Just for resolution of the whistling noise problem i had: It was the brakes! I was aware my pads were getting low (not low enough to trigger the sensors yet) and my brake disks were lipped but I couldn't pin this noise on the brakes. I replaced the pads and disks about a month ago and haven't had the sound since... so there we go!
It was a noise which was constant while cruising and got louder with speed.
lobbo is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa Giulietta

Tags
170 , climate , control , hunting , idle , sound , strange , tct , whistling

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome