75 TS starter motor replacement tips - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 1Likes
  • 1 Post By alfahaze
 
Thread Tools
(Post Link) post #1 of 7 Old 1 Week Ago Thread Starter
Status: -
AO Member
 
superjimbo's Avatar
 
Join Date: Feb 2009
Location: United Kingdom
County: Greater London
Posts: 286
75 TS starter motor replacement tips

Hi everyone,

My late Dadís old 75 TS LE has been off the road for quite a few years after an MOT failure, rust at the back end due to a leak in the boot.
It used to start and run fine but the starter motor has gone, it was on the way out for a while. I have a replacement starter and would like to try getting it started before putting it up for sale. Is there a fairly easy way of doing this? Iím no mechanic and it looks like iíd have to remove a lot of stuff to do it from the top, is it easier to do from underneath?
Iím 100 miles from the car and going up to Suffolk on Saturday to give it a try so any help is gratefully received.

Also, the petrol will be ancient, any tips on draining this so I can replace it?

Iíll post this on the main section too so sorry for any duplication.

Thanks for any help
superjimbo is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 7 Old 1 Week Ago
Status: Back to two Alfas
AO Silver Member
 
Unkle Munkle's Avatar
 
Join Date: Mar 2003
Location: United Kingdom
County: -
Posts: 1,934
My starter motor is far from great too so would like to jump on the back of this post for some top tips on removal and replacement.

It doesn't look particularly difficult - more a case of access I guess...
Unkle Munkle is offline  
(Post Link) post #3 of 7 Old 1 Week Ago Thread Starter
Status: -
AO Member
 
superjimbo's Avatar
 
Join Date: Feb 2009
Location: United Kingdom
County: Greater London
Posts: 286
Quote:
Originally Posted by Unkle Munkle View Post
My starter motor is far from great too so would like to jump on the back of this post for some top tips on removal and replacement.

It doesn't look particularly difficult - more a case of access I guess...
Yes, it's just unbolting and replacing from what I can tell but getting access is the problem.
superjimbo is offline  
(Post Link) post #4 of 7 Old 1 Week Ago
Status: -
AO Member
 
Join Date: Jun 2008
Location: Cambridge
Posts: 319

Member car:

1975 Alfetta GT

Before you swap the starter motor, carefully remove , clean and reinstall the engine ground strap. 9/10 this is the problem.
alfahaze is offline  
(Post Link) post #5 of 7 Old 1 Week Ago Thread Starter
Status: -
AO Member
 
superjimbo's Avatar
 
Join Date: Feb 2009
Location: United Kingdom
County: Greater London
Posts: 286
Quote:
Originally Posted by alfahaze View Post
Before you swap the starter motor, carefully remove , clean and reinstall the engine ground strap. 9/10 this is the problem.
Thanks. Apologies for my lack of knowledge but where would I find that? I presume itís not just the negative terminal from the battery?
superjimbo is offline  
(Post Link) post #6 of 7 Old 1 Week Ago
Status: -
AO Member
 
Join Date: Jun 2008
Location: Cambridge
Posts: 319

Member car:

1975 Alfetta GT

Quote:
Originally Posted by superjimbo View Post
Thanks. Apologies for my lack of knowledge but where would I find that? I presume itís not just the negative terminal from the battery?
It wouldn't hurt to do that one too. But the one I was talking about will be the big fat cable connected to the engine block. I can't recall exactly where it is bolted on the TS, its been a few years, you might have to have a hunt about.
superjimbo likes this.
alfahaze is offline  
(Post Link) post #7 of 7 Old 1 Week Ago Thread Starter
Status: -
AO Member
 
superjimbo's Avatar
 
Join Date: Feb 2009
Location: United Kingdom
County: Greater London
Posts: 286
Quote:
Originally Posted by alfahaze View Post
It wouldn't hurt to do that one too. But the one I was talking about will be the big fat cable connected to the engine block. I can't recall exactly where it is bolted on the TS, its been a few years, you might have to have a hunt about.
Thanks, I'll have a look
superjimbo is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 75, RZ, SZ

Tags
motor , replacement , starter , tips

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome