164 3.0 speedo - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 12-09-19 Thread Starter
Status: adds
AO Member
 
derek155's Avatar
 
Join Date: Jul 2007
Location: sale
County: cheshire
Posts: 439
164 3.0 speedo

hi, the speedo on my 164 always packs up when the engine gets hot, (above 90) after being in traffic, but always starts again when cooled off? what could it be?
derek155 is offline  
Sponsored Links
Advertisement
 
Status: Remembering why I dislike working on old cars....
AO Silver Member
 
ChrisS's Avatar
 
Join Date: Sep 2001
Location: Worcestershire
Posts: 2,712

Member car:

Mercedes C350e

The speedo sensor is electronic and on the gearbox, so could be that? Does it happen to coincide with the fan coming on maybe??
ChrisS is offline  
Status: Decidedly smug
AO Silver Member
 
Join Date: Sep 2006
Location: United Kingdom
County: Cumbria
Posts: 1,947
+1 for the gearbox sensor.
Avocet is offline  
(Post Link) post #4 of 6 Old 13-09-19 Thread Starter
Status: adds
AO Member
 
derek155's Avatar
 
Join Date: Jul 2007
Location: sale
County: cheshire
Posts: 439
thanks, i wonder if you can still get the sensor, any ideas? and is it an easy fix?
derek155 is offline  
Status: Decidedly smug
AO Silver Member
 
Join Date: Sep 2006
Location: United Kingdom
County: Cumbria
Posts: 1,947
Not sure about the 24V cars, but easy enough on the 12V cars, I think. Chris?
Avocet is offline  
(Post Link) post #6 of 6 Old 4 Weeks Ago
Status: Remembering why I dislike working on old cars....
AO Silver Member
 
ChrisS's Avatar
 
Join Date: Sep 2001
Location: Worcestershire
Posts: 2,712

Member car:

Mercedes C350e

You know.....I’m not 100% about the speedo on the 24V now. Did they shift to using the ABS for road speed then or later?? I’ve got memories of having to put the speedo gear and diff casing from a 12V box onto a 24V box when I put one in my kit car some years back. I finished up with a 6 speed GTA box in the end and converted to an electronic speedo.
ChrisS is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 164 & 166

Tags
164 , speedo

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome