Solved-Spider roof fault - Page 5 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 21Likes
Reply
 
Thread Tools
Status: -
AO Member
 
Join Date: Mar 2017
County: -
Posts: 113
Well, I can't fault Cayman Autos.

I didn't expect to get there so quickly but thanks to light holiday traffic I got there just as they were closing. The mechanic said that he was happy to stay and take a look, and if it was flap motors he'd replace them on the spot so I could drive home.

He concluded that it was either the motors or hinges. Motors were replaced on the spot under warranty which seemed to cure it - but if it misbehaves again under normal use they'll get some hinges in and swap them while I wait (I'm sure I could swap them myself if necessary).

So, no messing around with public transport home this evening - hopefully the roof now works. Although the weather makes it slightly irrelevant at the moment.
Dave964 is offline  
Sponsored Links
Advertisement
 
Status: turning heads everywhere
AO Gold Member
 
lussoman's Avatar
 
Join Date: Feb 2007
Location: Preston
County: Lancashire
Posts: 6,333
They sound like a good company.
I wish they'd open a northern branch!
lussoman is online now  
Status: -
AO Member
 
Join Date: Mar 2017
County: -
Posts: 113
Failed to close again this morning, so it wasn't the flap motors.
Will call Cayman later and arrange to get the hinges changed.
Dave964 is offline  
Status: turning heads everywhere
AO Gold Member
 
lussoman's Avatar
 
Join Date: Feb 2007
Location: Preston
County: Lancashire
Posts: 6,333
I'm surprised they've not mentioned the potential 'alignment' issue.
When I took mine in to the main dealer this was what was flagged-up straight away, what they were used to doing.
Something to do with the bulk of the roof mechanism ''shifting'' slightly over time, and therefore running out of alignment.
All they did was make a few adjustments and it was fine again for 6 to 12 months.
But after getting this done twice at £300 a pop, I'd had enough of throwing money at a seemingly ongoing problem.

I don't think Alfa ever had any faith in it, only covering it under warranty for the first 6 months of its life.
And surprisingly, it's a German contraption, so the usual Italian put-downs don't apply here.

Past: GTV T.Spark Lusso (owned 8 years) Present: 948 Spider LE (bought Nov. '10) Future: 8C (in my dreams )
Previously (selective): Porsche 944 Turbo; Porsche 944S; Jaguar XJ6; Audi Coupe; Mark 2 Golf GTI.
lussoman is online now  
Status: -
AO Member
 
Join Date: Mar 2017
County: -
Posts: 113
I'd be surprised if it's alignment - the problem doesn't seem to be the actual roof. It seems to be the lid of the roof compartment, which is why it seems likely it's related to the flaps.
Dave964 is offline  
Status: -
AO Member
 
Join Date: Mar 2017
County: -
Posts: 113
Took the car back to Cayman Autos last night for the hinges to be replaced - was done while I waited and took less than an hour. Parts were more than I was expecting (about £225 with VAT) but they did it labour free - they seem to feel responsible that they didn't fix it last time.
I am still in the phase of not trusting the roof, and therefore part of me suspects it is still broken. But it worked last night, and worked twice this morning so fingers crossed....
Dave964 is offline  
Status: -
AO Member
 
Join Date: Jun 2009
Location: United Kingdom
County: Merseyside
Posts: 405
Just ordered both sets of gas struts for my Spider and discovered that, I think, the wrong SGS part number for the 200NM struts has been mentioned in this thread. I was confused when searching using the original part number of 7456VP 200N. When you enter the first six digits, two struts come up. One is GSC3057, and is described as an 'Alfa Romeo Spider roof gas strut' with a pic of a 916 Spider next to it. But in small print underneath it says it's a bonnet strut. Also appearing is GSC3104 and described as an 'Alfa Romeo Brera roof strut'.

If you add the 200n to the search, the GSC3057 disappears leaving just the GSC3104. As we all know the Brera doesn't have a convertible top!

I called SGS and they confirmed that GSC3104 is the correct replacement for 7456VP 200N and that the description should say 'Brera Spider'.

Incidentally, The part number is one digit out from GSC3103, which are the replacements for the 100NM struts, 5579XQ 100N, which makes sense.

Here's the 200N strut:https://www.sgs-engineering.com/gsc3...era-roof-strut

And the 100N: https://www.sgs-engineering.com/gsc3...era-roof-strut

I hope this helps anyone looking to replace their struts.
lussoman likes this.
biancofreddo is offline  
Status: Hibernating
AO Member
 
Fitz750's Avatar
 
Join Date: Nov 2012
Location: Italy
County: Bergamo
Posts: 201
Garage
Changed both sets of struts using the SGS struts in the last weeks. Still had the hood popping up occasionally after changing only the 200N struts. Today changed the 100N struts And was all good after first test drive. Will have to see if it solves completely the issue.
The old 200N struts still had a little resistance, the 100N struts had no resistance at all.
Fitz750 is offline  
Status: -
AO Member
 
Join Date: May 2013
Location: Las Palmas
County: Spain
Posts: 72
Quote:
Originally Posted by yerbamateo View Post
Maybe it will prove useful, I attach formal instructions for both sets of struts.
Hi, do you have a specific Elearn for the spider? I thought there was only for Brera... Do you know where can I get one?
Gaincho is offline  
Status: -
AO Member
 
Join Date: May 2013
Location: Las Palmas
County: Spain
Posts: 72
Yet another happy customer here!!

Mine had the two usual and common failures: "Rear window catching", and "Temporaly roof failure" due to one of the rear flap motors. Following yerbamateo's guides, I've been able to fix both.

Changing gas struts was a real pain (big palms, short fingers...), but finally I succeded. And https://www.alfaowner.com/Forum/alfa-...ap-motors.html was really easy.

Now I can say I have a new convertible.
Gaincho is offline  
Status: -
Newbie
 
Join Date: Jul 2015
Location: Israel
County: -
Posts: 6

Member car:

Spider 2.2

Hi friends!
I need your help...
In last few months when i drive with the roof closed i can hear the noise of wind at right side (passenger side), it feels like the roof at that side is not tight enough.
I replaced the 4 short struts (2 in each side) but id didn't make nothing.
Another problem that i have is that the roof sometimes stucks while opening/closing.
I replaced in the past the 2 flap motors.
Few wekks ago it gets worse, i can't close the roof
Somebody also had theese problems and resolved them?

Thanks,
Leon.
Leon1984 is offline  
Status: -
Newbie
 
Join Date: Nov 2011
Location: Turkey
County: Izmir
Posts: 6
Today, I changed all four of the gas struts with the ones I bought from SGS Engineering (by the way it only took 25 mins to change all four, without stripping the hood ). The rear window does not catch on the roll bars anymore

Last edited by master149; 18-01-18 at 16:33.
master149 is offline  
Status: -
Newbie
 
Join Date: Jul 2018
County: United Kingdom
Posts: 2

Member car:

Brera Spider

Many thanks to all for their contributions - 4 struts from sgs and about 1hr of time - most of which was drilling out the 2 pop-rivets.
No more catching on the roll hoop or popping rear corner. Old ones were totally shot, could compress the 100N ones with my little finger!

Been a great summer to have a spider
BetterLateThan is offline  
Status: Leaning towards keeping the Spider
AO Member
 
Ryan_The_Spider's Avatar
 
Join Date: Jul 2011
Location: United Kingdom
County: Warwickshire
Posts: 623

Member car:

Giulia Veloce

To be fair the problems with the spider roof are mostly easy to fix.

The only hard bit is one my old one wiring had work hardened and became brittle so it had to be repaired.
Ryan_The_Spider is offline  
Status: -
Newbie
 
Join Date: Jan 2019
Posts: 1
Hi

I have the same issue need to replace the two struts , I’m new on here so bear with me please

I can see which struts need changing ie the 100N and the 200N just wondering how to access them if someone could advise please . Ignore this seen prev e learn post , didn't come up on the phone , now I'm on a PC its visible , so hopefully can work through it

Thanks

M

Last edited by mrv.105.mr; 07-01-19 at 07:48.
mrv.105.mr is online now  
Status: -
AO Member
 
Join Date: Jul 2010
Location: United Kingdom
County: Norfolk
Posts: 59
Quote:
Originally Posted by mrv.105.mr View Post
Hi

I have the same issue need to replace the two struts , I’m new on here so bear with me please

I can see which struts need changing ie the 100N and the 200N just wondering how to access them if someone could advise please . Ignore this seen prev e learn post , didn't come up on the phone , now I'm on a PC its visible , so hopefully can work through it

Thanks

M
The outer ones are easily visualised if you raise the rear section of the roof and look in.
The good book says to remove the old ones only at full extension but it's not at all necessary, usually they are so shot they have no power in them anyway but even if they are good they just pop off and extend gently.

Use a screwdriver to lever the strut off the mounting, it needs a bit of force but not too much. No need to do anything to the strut, just lever it off top and bottom.

Do one side at a time to keep a little support to the roof and as a reference point if you get lost.

The new ones go on by pushing them hard onto the mounting points, they may need a little tap with whatever you can get in there to hit 'em with.

The only warning is that if the roof section is up for more than about ten minutes, the hydraulic pressure falls and the section starts to drop, a bit at a time. It seems just possible that it may catch so it's wise to be quick if it starts to go, ignition on, lift the section again.

The inner ones are harder to get at but they are done from inside, same process but a bit less room to work. Quite do-able though at home.

Last tip, the struts have a right way up but I forget which way it is, it's mentioned in this thread somewhere. If desperate, just fit the new ones the same as the old ones and hope that they were in the right way. They will work fine if upside down but they may not last as long due to reduced lubrication. Hope that helps!
Tobenn is offline  
Status: -
Newbie
 
Join Date: Mar 2019
County: -
Posts: 3
Quote:
Originally Posted by yerbamateo View Post
Hi,

I was gonna open a new thread, but found this one describing exactly what I did today, so let me expand a little and give my thumbs up.

My 2007 Spider had two typical roof issues - rear window getting stuck on plastic embellishment of head hoops and arc corner sometimes slightly popping up after closure.
Both issues are solved, changing 2+2 gas struts inside the hood. Mine were totally shot, just as I suspect most of them are after couple of years (keep reading why).

First pair, upper one, rated at 100N, which seems to be responsible for tensioning the roof between 3rd and 4th arc. This keeps (heavy) rear window slightly up when going over the hoops. There´re also elastic straps, that go along each side of the window (photo below), which after couple of years loose elasticity - I pulled them slightly and made a knot, to tense them again.
Second pair of the struts, rated at 200N, keeps lower, fifth arc tensed and roof sealed to the cover. If the corner pops, or you need a lot of force to lock over-the centre struts, this most probably is the gas spring being dead weight.

My 100N springs were completely shot, no force whatsoever. The 200N, one had around 35N (causing shearing of the plastic cover on the hoop on that side), the other had around 120N.

For the replacement gas springs, you´re looking for Stabilus 2609NH and 2607NR. Avoid Alfa Service prices, they're double retail. Myself, I've fitted FA Krosno 23286 250N as lower springs, and Hahn Gasfedern 106729.2 + 2xPX22, charged to 150N (these are industrial quality springs, with valve to regulate or charge the spring, and steel ball mounts). FA Krosno you can get around here for 8-10 quid, Hahn are closer to 18-20 quid/piece. PM me, if you want some contacts here in Poland to get them, many places ship internationally. You basically want 155mm, 40mm displacement, 6/15 gas springs with fi10 ball mounting.

10 full cycles of opening/closing confirm that no issues whatsoever remain.

Removal/refitting is really easy, with just two rivets to drill (I've replaced them with small screws afterwards), and four screws to undo. PM me if you need a detailed procedure.

By the way, popping of the corner is also often caused by the rubber limiter on the over-the-center struts. Undo small allen screw that blocks it, and turn the rubber in.

Last but not least - why those gas springs break? When ordering my springs I spoke to the engineer that designs them, and apparently the biggest factor in gas springs loosing pressure is amount of vibrations, especially when extended.
Unlike gas springs in the boot, or any other places in the car, the ones in the roof are constantly vibrating with the roof up and the car at speed. This means that spring quality is paramount, but anyway they´ll die after 3-4 years anyway and should be replaced. (The ones in the boot can last even 20 years. My other Alfa proves that )

So, it was a good day in the garage, now I need a slightly warmer days to take the Spider for a spin...
Hi i live in Spain and having a problem to obtain the gas struts can you help with perches info please
ian jerrardo is offline  
Status: -
AO Member
 
Join Date: May 2013
Location: Las Palmas
County: Spain
Posts: 72
Quote:
Originally Posted by ian jerrardo View Post
Hi i live in Spain and having a problem to obtain the gas struts can you help with perches info please

Hi!


Perhaps you'd like to take a look at this:


https://www.alfistas.es/foro-alfista...0/post-1427173


Explained in spanish, and links to the gas struts.


Cheers!
Gaincho is offline  
Status: supporting a bank near you
AO Silver Member
 
Top Down's Avatar
 
Join Date: Apr 2009
Location: United Kingdom
County: West Sussex
Posts: 4,922
This is one of those threads which will keep reappearing from time to time. Today I replaced all 4 struts, nothing remarkable there, not now with all the help already posted here. Its not difficult once you crack the technique. This was my work method, and I hope it is a help to someone else. I found the lower struts are best changed with hood in its opening cycle the one end with the back of the hood cocked, you can see the lower strut at this point, attach the strut at the end nearest the hoods pivot point. The outer end can be attached with the rear cover lifted but before the hood starts to drop into the storage area, in doing this, and working by feel the strut only needs about 10mm compression. The process for gaining access to the upper ones, is as has already been said, with the hood closed and working from inside. What I found difficult was getting to the 2 x 5mm hex screws holding the plastic trim that the hood liner is attached to, just above the seat belt exit. I overcame this by starting the hood opening cycle where the back of the hood just lifts, you dont need a lot, but this relaxes the hood liner so you can lift the liner to get access to undo the screws. I did not drill out and pop rivits, I could not see any benefit and the job was not hindered by ignoring them.

The old struts were totally ex useful, they dont even qualify as an ornament! Now the hood clears the hoops and next job will be to repair and touch up the paint which has been worn off.

Full marks to the guys who started this thread and those who contributed the links to SGS with the part number for the struts. I guess in a few years I will be doing a search (again) for this thread to remind myself how I did the job this time. Yes, this post is for me as much as anyone!
lussoman and Alphamale like this.

Someone said to me, "so whats so special about an Alfa Romeo then?" I told him, "If you have to ask, you wont understand".

Giulia Super Lusso 2.0MA, wife drives 939 Spider 2.2, plus now a 147 1.6 TS whilst the Spider hibernates and there is a 1972 Spider 2000 S2 in the garage for fun days.

Previously, Brera 2.2 Prodrive - 159 SW 1.9JTDm

Last edited by Top Down; 1 Week Ago at 19:00.
Top Down is offline  
(Post Link) post #120 of 123 Old 4 Days Ago Thread Starter
Status: -
AO Member
 
Alphamale's Avatar
 
Join Date: Jul 2007
Location: South Leicestershire
Posts: 202
Quote:
Originally Posted by Top Down View Post
This is one of those threads which will keep reappearing from time to time. Today I replaced all 4 struts, nothing remarkable there, not now with all the help already posted here. Its not difficult once you crack the technique. This was my work method, and I hope it is a help to someone else. I found the lower struts are best changed with hood in its opening cycle the one end with the back of the hood cocked, you can see the lower strut at this point, attach the strut at the end nearest the hoods pivot point. The outer end can be attached with the rear cover lifted but before the hood starts to drop into the storage area, in doing this, and working by feel the strut only needs about 10mm compression. The process for gaining access to the upper ones, is as has already been said, with the hood closed and working from inside. What I found difficult was getting to the 2 x 5mm hex screws holding the plastic trim that the hood liner is attached to, just above the seat belt exit. I overcame this by starting the hood opening cycle where the back of the hood just lifts, you dont need a lot, but this relaxes the hood liner so you can lift the liner to get access to undo the screws. I did not drill out and pop rivits, I could not see any benefit and the job was not hindered by ignoring them.

The old struts were totally ex useful, they dont even qualify as an ornament! Now the hood clears the hoops and next job will be to repair and touch up the paint which has been worn off.

Full marks to the guys who started this thread and those who contributed the links to SGS with the part number for the struts. I guess in a few years I will be doing a search (again) for this thread to remind myself how I did the job this time. Yes, this post is for me as much as anyone!
Glad you sorted it, when I had the fault originally I was determined to get to the bottom of it, fortunately not an expensive fix, certainly not a disaster like some "experts" in garages said it was.
Alphamale is offline  
Status: supporting a bank near you
AO Silver Member
 
Top Down's Avatar
 
Join Date: Apr 2009
Location: United Kingdom
County: West Sussex
Posts: 4,922
We still do have a problem, sometimes the hood will fold faultlessly, other time it wont, it seems to be the opening cycle, once opened it will close OK. Now with the gas struts replaced we will get our Alfa specialist who has got it working in the past to take a look. We will ask him why he didnt suggest changing the gas struts to us.
Top Down is offline  
Status: supporting a bank near you
AO Silver Member
 
Top Down's Avatar
 
Join Date: Apr 2009
Location: United Kingdom
County: West Sussex
Posts: 4,922
Just found this web site, might just be useful!

https://roofmotors.co.uk/Alfa-Romeo
Top Down is offline  
Status: turning heads everywhere
AO Gold Member
 
lussoman's Avatar
 
Join Date: Feb 2007
Location: Preston
County: Lancashire
Posts: 6,333
Quote:
Originally Posted by Top Down View Post
Just found this web site, might just be useful!

https://roofmotors.co.uk/Alfa-Romeo
Good find.
But noticed the price of a new roof pump & motor unit. I wonder how many of those they sell...
lussoman is online now  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
fault , roof , solvedspider

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome