159 Fuel Gauge Sender Problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 15 Old 11-09-07 Thread Starter
Status: -
AO Member
 
Join Date: Apr 2007
Posts: 40

Member car:

Alfa 159

159 Fuel Gauge Sender Problems

After doing a quick search I see that lots of people have had problems with Alfa Fuel Gauges. But, did anyone ever get them sorted?

My problem is that if I fill the tank (to the brim) when the gauge is below 1/4 full it will always sit 1/8 off reading full. It doesn't matter what the terrrain it like or how long I leave it after filling, it will never get to the full mark.

If I fill the tank when the gauge is registering over a 1/4 full it will always register properly.

The dealer has said they manually tested the gauge and it seems fine but seem reluctant to do anything with the sender. I don't know why as I can never get to speak to the service manager or foreman in these situations, strangely they're always busy and you're left with the receptionist!!

Cheers in advance,

Eamon.
whittye is offline  
Sponsored Links
Advertisement
 
Status: 660Nm of torqueystuff!
AO Platinum Member
 
Hunter's Avatar
 
Join Date: Dec 2004
Location: British Indian Ocean Terr
County: -
Posts: 15,174
Re: 159 Fuel Gauge Sender Problems

Not sure about a problem with the 159's fuel gauge Mine has been fine so far

It was a problem with the 156's and I had a gauge, odometer and sender replaced under warranty on my old car. However the mileage was wiped to zero and started again.
Hunter is offline  
Status: Still Happily Married..........
AO Platinum Member
 
dpat's Avatar
 
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Re: 159 Fuel Gauge Sender Problems

What Hunter said about the 156 - mine was the same
dpat is offline  
Nev
Status: - Update
Guest
 
Posts: n/a
Re: 159 Fuel Gauge Sender Problems

Some people actually reported not being able
to brimfill their Breras a while back.

(i.e. the gauge was fine, they just couldn't
get a full tank of fuel in. )
 
(Post Link) post #5 of 15 Old 11-09-07 Thread Starter
Status: -
AO Member
 
Join Date: Apr 2007
Posts: 40

Member car:

Alfa 159

Re: 159 Fuel Gauge Sender Problems

Nah, I can fill to the brim alright (as I found out when I got a nice diesel splash back from the pump as I force fed the tank one click too many!!). I had a 146 with a similar problem and had to have the instrument cluster replaced. I'm not too keen to have that done again (even if the milege is zero'd) as the rattles and squeaks afterwards just weren't worth it! Thanks anyway guys. I'll post back when/if I get it resolved!

Last edited by whittye; 11-09-07 at 17:06.
whittye is offline  
Status: frenzied burrowing
AO Platinum Member
 
Fraser's Avatar
 
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Re: 159 Fuel Gauge Sender Problems

D'you know I don't know if it's a problem on mine. As long as it shows nearly full and my mpg's as expected I can't say it would bother me.
Fraser is offline  
(Post Link) post #7 of 15 Old 11-09-07 Thread Starter
Status: -
AO Member
 
Join Date: Apr 2007
Posts: 40

Member car:

Alfa 159

Re: 159 Fuel Gauge Sender Problems

The problem arises when you can't remeber wheather you last filled it when it was below the 1/4 mark or above it. If you thought you filled it when it was above the 1/4 mark but it was actually below it and the light comes on you may actually have 10-15 liters less than you thought! Not good driving through remote areas (not speaking from experience of course ).
whittye is offline  
(Post Link) post #8 of 15 Old 09-01-08 Thread Starter
Status: -
AO Member
 
Join Date: Apr 2007
Posts: 40

Member car:

Alfa 159

Re: 159 Fuel Gauge Sender Problems

Got this sorted eventually by having the tank sender replaced. The dealer tried resetting the ECU by disconnecting the battery and while the fuel gauge showed the correct reading after a reset, the reading went askew again when the tank was filled next time.

Thanks,

Eamon.
whittye is offline  
Status: Breraless :(
AO Platinum Member
 
Squadrone Rosso's Avatar
 
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 30,127
Re: 159 Fuel Gauge Sender Problems

I've reported this problem too but it depends where I fill up really. BP, reads under, Tesco is almost there and Shell is bang on
Squadrone Rosso is offline  
(Post Link) post #10 of 15 Old 10-01-08 Thread Starter
Status: -
AO Member
 
Join Date: Apr 2007
Posts: 40

Member car:

Alfa 159

Re: 159 Fuel Gauge Sender Problems

Your not measuring on a 50 fill each time are you !! Seriously though, I found that most forecourts are not dead level and depending on which way the tank is lying when filling, the gauge would read a significant difference. Drive the car in one way (passanger front side falling away from pump - can be bearly noticable) and the tank would read full. Drive in the other way (passanger front falling towards pump) and the tank could read 1/4 - 1/8 off full even though it had been filled to the brim, not just till the pump "clicked". Since I've had the sender replaced the readings seem to be a lot more consistent, only reading slightly off full when the car is pointing in the wrong direction. This reads correctly again when the car is driven back on the level again. Tried a few different brands too!
whittye is offline  
Status: Breraless :(
AO Platinum Member
 
Squadrone Rosso's Avatar
 
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 30,127
Re: 159 Fuel Gauge Sender Problems

Did getting the sender changed affect the fuel computer reading? Must get mine done I guess.
Squadrone Rosso is offline  
(Post Link) post #12 of 15 Old 11-01-08 Thread Starter
Status: -
AO Member
 
Join Date: Apr 2007
Posts: 40

Member car:

Alfa 159

Re: 159 Fuel Gauge Sender Problems

Certainly did on mine anyway. Bit of a struggle to get the dealer to do it but now that it's done the gauge is reading as it should. Best of luck!
whittye is offline  
Status: -
AO Member
 
Join Date: Sep 2009
Location: Japan
County: Kanagawa
Posts: 10
I recently started having problems on my 159 wagon. Yesterday I filled it from almost empty to full and the fuel gauge only read up to 1/3 of the gauge. I checked again this morning and it was still sitting on the 1/3 mark. I am thinking about calling the dealer to check the fuel sender. I tried all of the above methods but still to no avail.
britishracer is offline  
Status: -
AO Member
 
Join Date: May 2008
Posts: 21

Member car:

Alfa 147 GTA

Quote:
Originally Posted by Squadrone Rosso View Post
I've reported this problem too but it depends where I fill up really. BP, reads under, Tesco is almost there and Shell is bang on
Ha! I've had this problem for years, BP and Mobil/711 show under and Shell, as you say, is bang on. Did you ever work out why? Is one petrol a higher octane maybe?
Epicurus is offline  
(Post Link) post #15 of 15 Old 4 Weeks Ago
Status: -
AO Member
 
chris_w_65's Avatar
 
Join Date: Sep 2017
Location: Johannesburg
County: -South Africa
Posts: 127
Garage
Is the fuel gauge sender under the back seat on the 159 3.2JTS sedan
chris_w_65 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
159 , fuel , gauge , problems , sender

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome