Heating blowing cold - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 1Likes
  • 1 Post By Adam147
 
Thread Tools
(Post Link) post #1 of 21 Old 08-11-11 Thread Starter
Status: -
AO Member
 
Lees7's Avatar
 
Join Date: Oct 2011
Location: United Kingdom
County: Norfolk
Posts: 40

Member car:

Brera 2.2 sv

Heating blowing cold

Good evening all

My 2006 brera is blowing cold air on max heat but only on the drivers side any ideas what this problem could be?
Passenger side is lovely and toasty
Lees7 is offline  
Sponsored Links
Advertisement
 
Status: If I agreed with you, we'd both be wrong
AO Member
 
Elfred's Avatar
 
Join Date: Aug 2008
Location: United Kingdom
County: Hertfordshire
Posts: 899
This comes up a lot, if you do a search you will find loads of info. I recall the solution is simply to get the aircon system re-gassed.

Some good info here:-
https://www.alfaowner.com/Forum/alfa-...m-problem.html
Elfred is offline  
Status: Upset about lack of tapatalk support.
AO Silver Member
 
MarcG's Avatar
 
Join Date: Sep 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 1,564

Member car:

Brera S

Surely it's a feature?

The driver side is cold because you are a man, and the passenger side is hot because because it's for your lady, and from experience they are always cold?
MarcG is offline  
Status: kerbed alloy, oh b***ocks
AO Member
 
Adam147's Avatar
 
Join Date: Feb 2010
Location: United Kingdom
County: West Midlands
Posts: 149
Look in the drivers footwell and you will find the rod which controls the directional flaps on the heater box, i bet it has come off or is missing. As it is only blowing cold air on the passenger side this is most likely the problem.
Have seen this many times...
BenW91 likes this.
Adam147 is offline  
(Post Link) post #5 of 21 Old 09-11-11 Thread Starter
Status: -
AO Member
 
Lees7's Avatar
 
Join Date: Oct 2011
Location: United Kingdom
County: Norfolk
Posts: 40

Member car:

Brera 2.2 sv

Thanks for the info guys will have a read through.
Did think could need a re-gas but was looking for a point in the right direction.
Car is in for the dreaded cam chain change out so the Indy said he will have a quick look at it for me.
Will post up what I found incase it helps anyone out in the future
Thanks again guys
Lees7 is offline  
(Post Link) post #6 of 21 Old 25-11-11 Thread Starter
Status: -
AO Member
 
Lees7's Avatar
 
Join Date: Oct 2011
Location: United Kingdom
County: Norfolk
Posts: 40

Member car:

Brera 2.2 sv

Just picked the car up and Indy told me that it was a actuator deep inside the interior that flips the intake from cold to hot.
All good now
Lees7 is offline  
Status: -
Newbie
 
Join Date: Mar 2011
Location: United Kingdom
County: West Midlands
Posts: 6

Member car:

Brera 2.2SV

Hi Lees7
Did they say where the actutator is as my 2006 2.2SV doing the same for the last couple of days.
S.I.D is offline  
(Post Link) post #8 of 21 Old 19-12-11 Thread Starter
Status: -
AO Member
 
Lees7's Avatar
 
Join Date: Oct 2011
Location: United Kingdom
County: Norfolk
Posts: 40

Member car:

Brera 2.2 sv

Afraid he didn't say will try get hold of the indy and find out for you
Lees7 is offline  
Status: -
Newbie
 
Join Date: Mar 2011
Location: United Kingdom
County: West Midlands
Posts: 6

Member car:

Brera 2.2SV

Thanks. I've managed to sort it. In the drivers footwell on the centre console there was yellow plastic piece hanging loose like an arm with a elbow. On the end is a square peg that fits into a plug. Its a bit tight to get at but that sorted it. Thanks for the tip on where to start looking. :-)
S.I.D is offline  
barnz2000
Status: - Update
Guest
 
Posts: n/a
I have this problem on my car, I have looked and found the yellow plastic bar not connected but I cant see where it`s supposed to go. Does anyone have a pic of where it should go or can describe it for me?? Thanks
 
barnz2000
Status: - Update
Guest
 
Posts: n/a
I have managed to sort it now. Just for reference if anyone has the same fault if you remove the trim under the airbag below the steering wheel, (to do this just undo 2 plastic nuts and it just pulls off.) then you can see where the rod connects.
Attached Images
File Type: jpg 20150904_055908334_iOS.jpg (74.0 KB, 126 views)
 
Status: -
Newbie
 
Join Date: Mar 2011
Location: United Kingdom
County: West Midlands
Posts: 6

Member car:

Brera 2.2SV

When I did mine I accessed it from underneath from in the drivers footwell and reached up. It's a bit tight to reach but glad you sorted it.
Attached Images
File Type: jpg DSC_0179_1441454180733.jpg (23.9 KB, 82 views)
File Type: jpg DSC_0182_1441454185891.jpg (36.6 KB, 85 views)
S.I.D is offline  
Status: -
AO Member
 
melsaltas's Avatar
 
Join Date: Jan 2010
Location: Greece
County: Attica
Posts: 146
Hi everybody. Have the same problem myself. Cold air blowing on the drivers side, from the vent that is aimed at the door glass. All other vents have hot air.
Found the plastic piece in its place (mine is white and not yellow).
Is there a way to text the actuator? With multiecuscan?
Any other suggestions?
Thanks
melsaltas is offline  
Status: -
AO Platinum Member
 
MalcQV's Avatar
 
Join Date: Sep 2011
Location: United Kingdom
County: Greater Manchester
Posts: 13,439

Member car:

Office Chair.

Thankyou. I was beginning to lose hope . Drove out of the petrol station on Tuesday evening and the driver's side started to blow cool. Passenger side I realised later was toasty.

After bleeding the system as I assumed there was air in (there was not) and looking for the other bleed point which is somewhere near the back of the engine which I never found, I read this.
Little green plastic lever and connecting rod hanging free under the steering column.

I was already on Autotrader and the bay of E looking for a replacement. Not Alfa I might add

I'm not going anywhere, I'm just going.
Statements above are all my own opinion and not fact.
MalcQV is offline  
Status: T-5 Days to Unicorn Paradise
AO Platinum Member
 
TheGrimJeeper's Avatar
 
Join Date: Sep 2009
Location: France
County: Riviera
Posts: 38,319
Quote:
Originally Posted by Amateur
I was already on Autotrader and the bay of E looking for a replacement. Not Alfa I might add

There is a website called Alfaowner.com that is good for help in fixing technical niggles.
TheGrimJeeper is offline  
Status: -
AO Platinum Member
 
MalcQV's Avatar
 
Join Date: Sep 2011
Location: United Kingdom
County: Greater Manchester
Posts: 13,439

Member car:

Office Chair.

Quote:
Originally Posted by Tata4Now View Post
There is a website called Alfaowner.com that is good for help in fixing technical niggles.
Tsk, amateurs.
MalcQV is offline  
Status: -
Newbie
 
Join Date: Nov 2018
County: -
Posts: 2
Heater plastic lever and rod.

Hi. I have a same problem with heater, but i cannot find where can i order this plastic parts. Do you have any ideas?
Konkoly Istv√°n is offline  
Status: -
Newbie
 
Join Date: Mar 2011
Location: United Kingdom
County: West Midlands
Posts: 6

Member car:

Brera 2.2SV

Quote:
Originally Posted by Konkoly Istv√°n View Post
Hi. I have a same problem with heater, but i cannot find where can i order this plastic parts. Do you have any ideas?
Hi has the plastic broken or just come off as on my Brera it had come away from the pin at the top and I pushed it back in to place
A bit awkward to get at as you’ll need to get your head into the footwell to see under
S.I.D is offline  
Status: -
Newbie
 
Join Date: Mar 2011
Location: United Kingdom
County: West Midlands
Posts: 6

Member car:

Brera 2.2SV

i have attached the photos of the arm and the pale yellow part that comes away but stays attached to the arm
Attached Images
File Type: jpeg 8B8F3223-BF84-418C-90BA-E8B5EEFA20E4_1543744497942.jpeg (18.4 KB, 19 views)
File Type: jpeg 55A720F3-E260-46FC-AABF-FCFFDC175510_1543744529949.jpeg (15.1 KB, 19 views)
S.I.D is offline  
Status: -
Newbie
 
Join Date: Nov 2018
County: -
Posts: 2
My problem is, both of them are missing...
Konkoly Istv√°n is offline  
Status: -
Newbie
 
Join Date: Mar 2011
Location: United Kingdom
County: West Midlands
Posts: 6

Member car:

Brera 2.2SV

Quote:
Originally Posted by Konkoly Istv√°n View Post
My problem is, both of them are missing...
sorry not had to buy any. I use AlfaLusso via ebay for some of my parts or try a local breakers yard if they breaking one
Hopefully one of these will help source it

Last edited by S.I.D; 08-12-18 at 20:52.
S.I.D is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
blowing , cold , heating

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome