Alfa Romeo 159 - Radiator fan stays on from cold engine. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 2 Old 24-05-19 Thread Starter
Status: -
Newbie
 
Join Date: May 2019
County: -
Posts: 1
Question Alfa Romeo 159 - Radiator fan stays on from cold engine.

Hello there

I have an Alfa Romeo 159 1.9 JTDM
I love the car, but i sure have had a lot of problems due to alot of parts that needed to be changed.

Recent thing i had to change was the Thermostat, and well, it was quite succesfull, before hand it got too hot, now it keeps the temperature at 90C as it should and doesnt go over. (Or so the gauge says.)
The problem is that after the switch of the thermostat it keeps turning on the radiator fan and its driving me crazy.

So far we have checked the relay which seems to be fine, we have checked the cables which seems to be fine as well.
The gauge in the car works as it should, and it doesn't overheat.

I have had all cooling turned off and AC turned off due to getting told that this might be the problem, or the problem might be related. sadly it wasn't.

Now im kinda empty, i have no idea to why it keeps turning the fan on, because if im to believe the gauge it should be sending the correct temperatures. And the fan is suppose to first go on when its needed and as far as i know it shouldn't be needed when the engine is cold

Any ideas?

Regards
Mike
mikebsorensen is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
Join Date: Nov 2012
Location: Wiltshire
County: -
Posts: 2,076
What make thermostat did you fit? Have you scanned engine ECU for faults?
Could be the coolant temp sensor is playing up so ECU puts fan on?
johnnyroper is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
159 , alfa , cold , engine , fan , radiator , romeo , stays

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome