Alfa 159 no boost when cold - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 10-11-18 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2016
County: -
Posts: 11
Alfa 159 no boost when cold

Hi guys after enjoying the car 159 1.9 2008 .now it seems there is a new problem.
Bad idling (il post video soon) care shakes when idling.
No boost whrn the car is cold.
Cant achieve 1.6 bar .
Cant seem to find any leaks in turbo hose.
Egr blanked dpf removed swirl flapd removed.
What the hell is going on?
Im thinking of vacuum pump .
alfamorocco is offline  
Sponsored Links
Advertisement
 
Status: Quo!
AO Silver Member
 
alfaitalia's Avatar
 
Join Date: Jan 2010
Location: United Kingdom
County: West Sussex
Posts: 2,495
Fault codes? Engine management light on?
alfaitalia is online now  
(Post Link) post #3 of 6 Old 10-11-18 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2016
County: -
Posts: 11
Nope nothing. Just u started it its cold no boost. As it achieve more then 70C the turbo start responding.
alfamorocco is offline  
Status: -
AO Silver Member
 
Join Date: Nov 2012
Location: Wiltshire
County: -
Posts: 2,069
Vac pump is an easy check get a mitivac on outlet when cold see what vac it’s making looking upwards of 20hgvac, if ok check output from boost control solenoid again at idle should be roughly what pump is putting out.
check the VNT actuator on turbo is pulling fully on the vnt mechanism,if not check for tightness in the vane assembly
johnnyroper is offline  
(Post Link) post #5 of 6 Old 12-11-18 Thread Starter
Status: -
AO Member
 
Join Date: Mar 2016
County: -
Posts: 11
Quote:
Originally Posted by johnnyroper View Post
Vac pump is an easy check get a mitivac on outlet when cold see what vac itís making looking upwards of 20hgvac, if ok check output from boost control solenoid again at idle should be roughly what pump is putting out.
check the VNT actuator on turbo is pulling fully on the vnt mechanism,if not check for tightness in the vane assembly
okey man il check these out and tell you.
alfamorocco is offline  
Status: -
AO Member
 
Join Date: Oct 2012
Location: United Kingdom
County: North Yorkshire
Posts: 243
Shake on idling -poor idling could be caused by excessive back pressure from DPF -does it start rough?
When did it last regenerate?
Could also cause lack of performance -poor mpg.
Paul777 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

Tags
159 , alfa , boost , cold

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome