Alfadiag won't connect - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 17 Old 16-04-09 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: South Africa
County: Gauteng
Posts: 97
Alfadiag won't connect

Hi there

Just got my OBD II cable from ECUFIX USB ISO OBD-II / VAGCOM / AlfaDiag KKL Interface keywords [USBVAGCOM] - 24.99 : ECUFix.com, Affordable Technology.
But i can't seem to connect to the ECU. I am using Alfadiag demo to test before i buy. I have tried changing the timeout settings, but it makes no difference. I'm getting the following error.

Quote:
Error: System.NullReferenceException: Object reference not set to an instance of an object.
at AlfaDiag.FormConfigDevice.c()
at AlfaDiag.FormConfigDevice.a()
Error: System.NullReferenceException: Object reference not set to an instance of an object.
at AlfaDiag.FormConfigDevice.c()
at AlfaDiag.FormConfigDevice.a()
Error: System.NullReferenceException: Object reference not set to an instance of an object.
at AlfaDiag.FormConfigDevice.c()
at AlfaDiag.FormConfigDevice.a()
================================================== ==================================================
[2009/04/16 04:30:41 PM] Testing: Bosch EDC16C8 Using Device: FTDI Device Version: 3.2.1.0
================================================== ==================================================
UseUSB: True
SerialPort:
KwpTiming:
RequestInterByteTime: 0
EcuResponseTimeout: 1500
EcuResponseInterbyteTimeout: 100

IsoTiming:
RequestInterByteTime: 0
EcuResponseTimeout: 2000
EcuResponseInterbyteTimeout: 150


Error: System.DllNotFoundException: Unable to load DLL 'FTD2XX.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
at bx.FT_Open(UInt32 A_0, IntPtr& A_1)
at a.l()
at ci.a(DeviceConfiguration A_0)
at AlfaDiag.FormConfigDevice.a()
Error: System.NullReferenceException: Object reference not set to an instance of an object.
at AlfaDiag.FormConfigDevice.c()
at AlfaDiag.FormConfigDevice.a()
Error: System.NullReferenceException: Object reference not set to an instance of an object.
at AlfaDiag.FormConfigDevice.c()
at AlfaDiag.FormConfigDevice.a()
Does anyone know what this means or how to fix it.

Thanks
Lourens is offline  
Sponsored Links
Advertisement
 
Status: -
 
Join Date: Oct 2008
Posts: 4,646
Re: Alfadiag won't connect

did you download the latest FTDI drivers from FTDI Chip Home Page

look for VCP port drivers.
SEARs is offline  
Status: -
 
Join Date: Oct 2008
Posts: 4,646
Re: Alfadiag won't connect

this thread might help:

Alfa Romeo forum: Alfa Diag or OBD II Freeware
SEARs is offline  
(Post Link) post #4 of 17 Old 16-04-09 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: South Africa
County: Gauteng
Posts: 97
Re: Alfadiag won't connect

I have installed the driver on the cd that came with the cable. It gave me a VCP on port 4. I have tried both the VCP and FTDI drivers.
When using the FDTI driver i got the following report.
Quote:
================================================== ==================================================
[2009/04/16 04:48:21 PM] Testing: Bosch EDC16C8 Using Device: FTDI Device Version: 3.2.1.0
================================================== ==================================================
UseUSB: True
SerialPort:
KwpTiming:
RequestInterByteTime: 0
EcuResponseTimeout: 1500
EcuResponseInterbyteTimeout: 100

IsoTiming:
RequestInterByteTime: 0
EcuResponseTimeout: 2500
EcuResponseInterbyteTimeout: 150


Sending bytes: [ 55 AA 55 AA 55 AA 55 AA ]
Received bytes:[ 55 AA 55 AA 55 AA 55 AA ]
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 6 Received Bytes: 6 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
[ C1 EF 8F ]
Expected Bytes: 7 Received Bytes: 7 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
[ C3 00 00 FF 00 FF 00 ]
Expected Bytes: 7 Received Bytes: 7 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
[ C3 02 32 02 6E 14 0A ]
Expected Bytes: 12 Received Bytes: 12 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
[ 7F 83 12 ]
Expected Bytes: 7 Received Bytes: 7 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
[ 7F 21 12 ]
Test Complete


When using the VCP port driver i got this report.

Quote:
[2009/04/16 05:10:35 PM] Testing: Bosch EDC16C8 Using Device: COM4 : VCP0 Version: 3.2.1.0
================================================== ==================================================
UseUSB: False
SerialPort: COM4
KwpTiming:
RequestInterByteTime: 0
EcuResponseTimeout: 1500
EcuResponseInterbyteTimeout: 100

IsoTiming:
RequestInterByteTime: 0
EcuResponseTimeout: 2500
EcuResponseInterbyteTimeout: 150


Sending bytes: [ 55 AA 55 AA 55 AA 55 AA ]
Received bytes:[ 55 AA 55 AA 55 AA 55 AA ]
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 6 Received Bytes: 6 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
[ C1 EF 8F ]
Expected Bytes: 7 Received Bytes: 7 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
[ C3 00 00 FF 00 FF 00 ]
Expected Bytes: 7 Received Bytes: 7 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
[ C3 02 32 02 6E 14 0A ]
Expected Bytes: 12 Received Bytes: 12 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
[ 7F 83 12 ]
Expected Bytes: 7 Received Bytes: 7 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
Expected Bytes: 1 Received Bytes: 1 Total wait time: 0 ms
[ 7F 21 12 ]
Test Complete
Lourens is offline  
Status: -
Unregistered
 
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Re: Alfadiag won't connect

Reinstall the drivers, turn off any WiFi and ensure the port is selected correctly in Alfadiags options.
Smaky is offline  
(Post Link) post #6 of 17 Old 16-04-09 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: South Africa
County: Gauteng
Posts: 97
Re: Alfadiag won't connect

Ok thanks i will give it a try.
Lourens is offline  
Status: Gold Member
AO Gold Member
 
rarebear's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,032

Member car:

911, 156, Merc C

Re: Alfadiag won't connect

This story is the reason I test all cables that I modify before sending them to innocent AO members. I don't think Ecufix does that....
rarebear is offline  
Status: -
AO Member
 
Join Date: Jan 2008
Location: Oxford
Posts: 336

Member car:

156 selespeed

Re: Alfadiag won't connect

I had an issue the other day with Alfadiag losing com's randomly.
Turned out to be the wifi that caused the problem.
Wifi switched OFF, no more problems!!

Thanks Rarebear for the cable - works a treat!
stoyce is offline  
(Post Link) post #9 of 17 Old 17-04-09 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: South Africa
County: Gauteng
Posts: 97
Re: Alfadiag won't connect

I finally managed to connect to the ECU using Alfadiag demo. It seems i have the EDC15C7 ECU. Is this possible ? I thought the 156 2.4 JTD 20V uses the EDC16C8. It's a 2005/6 model.
Lourens is offline  
(Post Link) post #10 of 17 Old 17-04-09 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: South Africa
County: Gauteng
Posts: 97
Re: Alfadiag won't connect

Can anyone tell me if my car uses the EDC16C8 and why Alafadiag won't connect when I choose this ECU, but connects when I choose the EDC15C7 ?
Lourens is offline  
(Post Link) post #11 of 17 Old 17-04-09 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: South Africa
County: Gauteng
Posts: 97
Re: Alfadiag won't connect

Has anyone sucsessfully used VAG-Com with the KKL interface to diagnose and clear faults on the EDC16C8 ECU's ?
Lourens is offline  
Status: -
 
Join Date: Oct 2008
Posts: 4,646
Re: Alfadiag won't connect

Quote:
Originally Posted by Lourens View Post
Can anyone tell me if my car uses the EDC16C8 and why Alafadiag won't connect when I choose this ECU, but connects when I choose the EDC15C7 ?
if it connects then thats all you want.
SEARs is offline  
Status: -
 
Join Date: Oct 2008
Posts: 4,646
Re: Alfadiag won't connect

Quote:
Originally Posted by Lourens View Post
Has anyone sucsessfully used VAG-Com with the KKL interface to diagnose and clear faults on the EDC16C8 ECU's ?
VAG-COM s/w will NOT communicate with Alfas
SEARs is offline  
(Post Link) post #14 of 17 Old 19-04-09 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: South Africa
County: Gauteng
Posts: 97
Re: Alfadiag won't connect

I finally took the plunge and forked out for Alfadiag. Hooked it up to my car and got the following error code.
Quote:
P1238
Failed Component Code: Air control negative governor deviation
Fault Symptom: Negative governor deviation above limit
Warning Lamp Status: Warning Lamp Illuminated
Fault Test State: Test not complete for this Error.
Fault Code Storage State: Error Not Present at time of request
Event Count: 40 count
Environmental Condition One: Engine Speed: 1647.1 rpm
Environmental Condition Two: Fuel Quantity: 9.41 mm3/str
Environmental Condition Three: Accelerator Pedal: 9.8 %
Environmental Condition Four: Rail Pressure: 556.85 Bar
Environmental Condition Five: Turbo Pressure: 1011.79 mBar
Environmental Condition Six: Engine Temperature: 83.78 C
I've done a search and came across a few different explanations for this spicific code, from
Quote:
Error – P1238 Air quantity to
P1238 Fuel Pump Secondary Circuit Malfunction
My code seems to have a different meaning, can someone tell me what it means ?
Lourens is offline  
Status: -
 
Join Date: Oct 2008
Posts: 4,646
Re: Alfadiag won't connect

for different ecu types [ JTD's Vs TS or JTS the same code cna mena different things.

As your car is a JTD the error seems to be turbo/egr related.

I'm no expert on JTDs but i'm sure a JTD expert will be along soon.
SEARs is offline  
(Post Link) post #16 of 17 Old 19-04-09 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: South Africa
County: Gauteng
Posts: 97
Re: Alfadiag won't connect

I had the turbo replaced a while back, and recently blanked off the EGR valve.
So it could be either component. Hopefully someone could help me narrow it down.
Lourens is offline  
(Post Link) post #17 of 17 Old 20-04-09 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2008
Location: South Africa
County: Gauteng
Posts: 97
Re: Alfadiag won't connect

Bump
Lourens is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
alfadiag , connect

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome