Disabling alarm on 156 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 7Likes
  • 2 Post By Fruity
  • 2 Post By gwinter
  • 2 Post By dgmayhead
  • 1 Post By Fruity
 
Thread Tools
(Post Link) post #1 of 13 Old 3 Weeks Ago Thread Starter
Status: -
AO Member
 
kernowkarmann's Avatar
 
Join Date: Feb 2008
Location: United Kingdom
County: Cornwall
Posts: 95
Disabling alarm on 156

Hi, One of the first things I did when I got my 156 9 years ago was to disable the annoying beeps when you lock the car.

Now as it approaches old age it has started to develop the even more annoying habit of setting the alarm off randomly.

Basically, is there anyway of disabling the alarm? No ones going to nick it, it's only worth a couple of hundred quid but the neighbours may smash it up if it goes off at night!
kernowkarmann is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 13 Old 3 Weeks Ago
Status: -
AO Member
 
Psircos@gmail's Avatar
 
Join Date: May 2017
County: -
Posts: 443
Quote:
Originally Posted by kernowkarmann View Post
Hi, One of the first things I did when I got my 156 9 years ago was to disable the annoying beeps when you lock the car.

Now as it approaches old age it has started to develop the even more annoying habit of setting the alarm off randomly.

Basically, is there anyway of disabling the alarm? No ones going to nick it, it's only worth a couple of hundred quid but the neighbours may smash it up if it goes off at night! [IMG class=inlineimg]https://www.alfaowner.com/Forum/images/smilies/blabla.gif[/IMG]
Im afraid this might not be of huge help as ive not heard this question before but maybe finding the audio output ie the speaker or whatever the noise comes out of and disconnect or remove it/them!?
[email protected] is offline  
(Post Link) post #3 of 13 Old 3 Weeks Ago
Status: -
AO Member
 
Psircos@gmail's Avatar
 
Join Date: May 2017
County: -
Posts: 443
Thinking it through a bit further, the ecu might notice the difference in load if the speaker is removet and, think someone is nicking the car(if the engineers were clever enough)

You may have to solder in a resistor of equivalent ohmage in-line .....but maybe not
[email protected] is offline  
(Post Link) post #4 of 13 Old 3 Weeks Ago
Status: -
AO Member
 
Join Date: Jul 2014
Location: Scotland
County: Falkirk
Posts: 787

Member car:

159SW;20VT Coupe

If you lock it with the key (not remote fob) the alarm won't set otherwise you can disconnect it in the passenger inner wing.
Davffc is offline  
(Post Link) post #5 of 13 Old 3 Weeks Ago
Status: -
AO Member
 
Psircos@gmail's Avatar
 
Join Date: May 2017
County: -
Posts: 443
There you go....a much simpler solution 👍
[email protected] is offline  
(Post Link) post #6 of 13 Old 3 Weeks Ago Thread Starter
Status: -
AO Member
 
kernowkarmann's Avatar
 
Join Date: Feb 2008
Location: United Kingdom
County: Cornwall
Posts: 95
Quote:
Originally Posted by Davffc View Post
you can disconnect it in the passenger inner wing.
easy to do?
kernowkarmann is offline  
(Post Link) post #7 of 13 Old 3 Weeks Ago
Status: -
AO Silver Member
 
Join Date: Jan 2018
County: -
Posts: 2,092
Jack up front left. Remove wheel. Remove plastic wheelarch splash shield to gain access to siren. Siren is at the top to rear of the top wishbone.

It's not hard but a bit fiddly- especially refitting the splash shield.

The only issue is the hazard lights will still trigger if alarm is set as you are treating symptoms, not the condition.

I'd want to see what is triggering the alarm. If alarm has been triggered, when disarming the alarm, how many times does the dash mounted LED in front of check panel flash? That indicates the zone which has been triggered.
1 flash: right front door.
2 flashes: left front door.
3 flashes: right rear door.
4 flashes: left rear door.
5 flashes: volumetric sensors.
6 flashes: bonnet.
7 flashes: boot.
8 flashes: tampering with starting cables.
9 flashes: tampering with battery/ cutting emergency key cables.
10 flashes: at least 3 causes of alarm.

See page 11 of owners' manual.

Of course, as per Davffc's advice, just lock by turning key in door lock barrel means none of the above is necessary.

Last edited by Fruity; 3 Weeks Ago at 21:52.
Fruity is offline  
(Post Link) post #8 of 13 Old 3 Weeks Ago
Status: -
AO Member
 
Join Date: Mar 2018
Location: New Zealand
Posts: 110

Member car:

156 2.5 V6

I've driven a 156 which no matter how you locked it, or even if didn't lock the car the alarm always set after 30 seconds or so. Despite being essentially the same car as the one I own it was a little different in the alarm department.

My car when locked with the remote makes one beep, then a couple of seconds later makes another beep. Whereas some 156's only make one beep.

The siren unit is not hard to get to, as outlined above. Unplugging it will stop the sound at least.
mikesalfa is offline  
(Post Link) post #9 of 13 Old 2 Weeks Ago
Status: -
AO Silver Member
 
Join Date: Jan 2018
County: -
Posts: 2,092
When alarm is set, a secondary beep a few seconds after the first indicates a fault somewhere and the detected faulty zone will not be monitored. Usual suspects are door hinge wiring or a damaged wire in the rubber conduit to the boot lid.

If the alarm sets itself, it must passively self-arm. This may be a configurable option in alarm menu. I don't know how to change that and I have never tried. I do know there have been threads on how to change the country selection of the alarm which I think can enable/disable the beeps and enable/disable self arming.
dgmayhead and proinsias like this.
Fruity is offline  
(Post Link) post #10 of 13 Old 2 Weeks Ago
Status: -
AO Member
 
Join Date: Dec 2014
County: -
Posts: 142

Member car:

156

Unit above passenger the wheel arch cover is the alarm module itself.
If you unplug it there will be no more alarm system. The remote locking still works as that is a separate unit below the rear parcel shelf. But without the alarm unit when you remote lock or unlock there will be no audible beep nor any visual cue (flashing hazard light).
dgmayhead and Fruity like this.
gwinter is offline  
(Post Link) post #11 of 13 Old 2 Weeks Ago
Status: -
AO Silver Member
 
dgmayhead's Avatar
 
Join Date: Nov 2013
Location: United Kingdom
County: Gwynedd
Posts: 2,210
I maybe getting confused as I've not had my 156 for a while but I think a long press like 5 seconds on the key fob locked the car but disabled the alarm. Might be worth a try . Sorry if I dreamt this but I'm sure I had to do this when it was on a trailer.

The beep after the close beep means the doors, boot or bonnet aren't closed correctly. I used to fix this by slamming everything a couple of times. Bonnet was the usual culprit on mine.

Sent from my BBB100-2 using Tapatalk
proinsias and Fruity like this.
dgmayhead is offline  
(Post Link) post #12 of 13 Old 2 Weeks Ago
Status: -
AO Silver Member
 
Join Date: Jan 2018
County: -
Posts: 2,092
Your memory works well.
Page 13 of owners manual states "pressed for more than 4 seconds when engaging the system.

This condition is shown by a series of 5 beeps in quick succession..."

It needs done every time but means that the alarm doesn't need removed before the faulty zone is repaired.
proinsias likes this.
Fruity is offline  
(Post Link) post #13 of 13 Old 2 Weeks Ago
Status: -
AO Member
 
Join Date: Mar 2018
Location: New Zealand
Posts: 110

Member car:

156 2.5 V6

Thanks for the info on the couple of beeps after alarm set. I guess it's a door wiring problem as the speakers work intermittently as well. Despite central locking working on all doors, and electric window functions. Main thing is that it locks the car really.
mikesalfa is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
156 , alarm , disabling

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome